summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Degros <fdegros@chromium.org>2020-03-20 13:47:13 +1100
committerJoonas Niilola <juippis@gentoo.org>2020-03-26 09:22:01 +0200
commitf8414fc9a46301d62289a316ecfc613690ff4ef4 (patch)
tree1d2a8175f7af1085dd5493c47065d0f9cb396e2b /sys-fs/rar2fs/rar2fs-1.29.0.ebuild
parentsys-fs/rar2fs: add proxied maintainer (diff)
downloadgentoo-f8414fc9a46301d62289a316ecfc613690ff4ef4.tar.gz
gentoo-f8414fc9a46301d62289a316ecfc613690ff4ef4.tar.bz2
gentoo-f8414fc9a46301d62289a316ecfc613690ff4ef4.zip
sys-fs/rar2fs: version bump to 1.29.0
Signed-off-by: François Degros <fdegros@chromium.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/rar2fs/rar2fs-1.29.0.ebuild')
-rw-r--r--sys-fs/rar2fs/rar2fs-1.29.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/rar2fs-1.29.0.ebuild b/sys-fs/rar2fs/rar2fs-1.29.0.ebuild
new file mode 100644
index 000000000000..e7b7be74efd1
--- /dev/null
+++ b/sys-fs/rar2fs/rar2fs-1.29.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
+HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
+SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Note that upstream unrar sometimes breaks ABI without updating the SONAME
+# version so try rebuilding rar2fs if it doesn't work following an unrar
+# upgrade.
+RDEPEND=">=app-arch/unrar-5:=
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+
+ econf \
+ --with-unrar="${ESYSROOT}"/usr/include/libunrar \
+ --disable-static-unrar \
+ $(use_enable debug)
+}