summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-11-26 20:59:07 +0100
committerSebastian Pipping <sping@gentoo.org>2022-11-26 21:05:06 +0100
commita994a0b2d57f4bf273c7adcc7ccfb96756d11b3a (patch)
treeb0d452ea47d5f7202548505f0475cda5bae36fdd /sys-fs/unionfs-fuse/unionfs-fuse-3.2.ebuild
parentdev-lang/gnat-gpl: drop 2020 (diff)
downloadgentoo-a994a0b2d57f4bf273c7adcc7ccfb96756d11b3a.tar.gz
gentoo-a994a0b2d57f4bf273c7adcc7ccfb96756d11b3a.tar.bz2
gentoo-a994a0b2d57f4bf273c7adcc7ccfb96756d11b3a.zip
sys-fs/unionfs-fuse: 3.2 + sync 9999
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'sys-fs/unionfs-fuse/unionfs-fuse-3.2.ebuild')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-3.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-3.2.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-3.2.ebuild
new file mode 100644
index 000000000000..8a0d27e6c74e
--- /dev/null
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-any-r1 toolchain-funcs
+
+DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
+HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
+SRC_URI="https://github.com/rpodgorny/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-fs/fuse:3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+python_check_deps() {
+ use test || return 0
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+src_test() {
+ [[ -e /dev/fuse ]] || return 0
+ addwrite /dev/fuse
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}