summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-23 16:17:37 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-23 16:19:21 -0700
commit198b4955b68f87f1c35e7aeecfea52634f026d2b (patch)
tree8ef8d9536720eed830d69723b1f0d3e7dd1ccc2b /sys-fs
parentapp-emulation/x48: properly update metadata this time (diff)
downloadgentoo-198b4955b68f87f1c35e7aeecfea52634f026d2b.tar.gz
gentoo-198b4955b68f87f1c35e7aeecfea52634f026d2b.tar.bz2
gentoo-198b4955b68f87f1c35e7aeecfea52634f026d2b.zip
sys-fs/zfs: set gentoo revision for utils
we already do that for kmod Release: field in the top level META file. downstream packagers are free to modify the release string as they see fit. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index e24458b4194f..129f34845447 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -98,7 +98,12 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == "9999" ]] && eautoreconf
+ if [[ ${PV} == "9999" ]]; then
+ eautoreconf
+ else
+ # Set revision number
+ sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
+ fi
# Update paths
sed -e "s|/sbin/lsmod|/bin/lsmod|" \
@@ -170,6 +175,12 @@ src_install() {
}
pkg_postinst() {
+ if has_version "<=sys-kernel/genkernel-3.5.3.3"; then
+ einfo "genkernel version 3.5.3.3 and earlier does NOT support"
+ einfo " unlocking pools with native zfs encryption enabled at boot"
+ einfo " use dracut or genkernel-9999 if you requre this functionality"
+ fi
+
if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then
einfo "Adding ${P} to the module database to ensure that the"
einfo "kernel modules and userland utilities stay in sync."