summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-02 02:52:28 +0000
committerSam James <sam@gentoo.org>2022-12-02 02:52:28 +0000
commit8dce8b45f0c15ecff4018fe7a9ae3af87cf91f71 (patch)
tree936397dc9800bb0d5a3311c604034cb3f6d63f54 /sys-fs
parentnet-analyzer/net-snmp: fix LDFLAGS ordering; rebase patches (diff)
downloadgentoo-8dce8b45f0c15ecff4018fe7a9ae3af87cf91f71.tar.gz
gentoo-8dce8b45f0c15ecff4018fe7a9ae3af87cf91f71.tar.bz2
gentoo-8dce8b45f0c15ecff4018fe7a9ae3af87cf91f71.zip
sys-fs/zfs-kmod: sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
index 8edf8733327b..faa5875ad758 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools dist-kernel-utils flag-o-matic linux-mod toolchain-funcs
@@ -21,12 +21,12 @@ else
S="${WORKDIR}/zfs-${PV%_rc?}"
ZFS_KERNEL_COMPAT="6.0"
- # increments minor eg 5.14 -> 5.15, and still supports override.
+ # increments minor eg 5.14 -> 5.15, and still supports override.
ZFS_KERNEL_DEP="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
ZFS_KERNEL_DEP="${ZFS_KERNEL_DEP%%.*}.$(( ${ZFS_KERNEL_DEP##*.} + 1))"
if [[ ${PV} != *_rc* ]]; then
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~sparc"
fi
fi