summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-30 01:26:08 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-30 01:37:49 -0500
commit3755c12fdf343ebe3878203f82b2780815a0fb8b (patch)
treedac9bce8ab847b5e52f993d8b76156875aca713b /sys-kernel/linux-headers/linux-headers-4.10.ebuild
parentsys-kernel/linux-headers: mark 4.13 m68k/s390/sh stable #640080 (diff)
downloadgentoo-3755c12fdf343ebe3878203f82b2780815a0fb8b.tar.gz
gentoo-3755c12fdf343ebe3878203f82b2780815a0fb8b.tar.bz2
gentoo-3755c12fdf343ebe3878203f82b2780815a0fb8b.zip
sys-kernel/linux-headers: drop old non-lts versions before 4.13
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-4.10.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-4.10.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-4.10.ebuild b/sys-kernel/linux-headers/linux-headers-4.10.ebuild
deleted file mode 100644
index bdd75e6655cb..000000000000
--- a/sys-kernel/linux-headers/linux-headers-4.10.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 bfin cris frv hexagon hppa ia64 m32r m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 s390 score sh sparc tile x86 xtensa"
-inherit kernel-2
-detect_version
-
-PATCH_VER="1"
-SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.xz
- ${PATCH_VER:+mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
-
-DEPEND="app-arch/xz-utils
- dev-lang/perl"
-RDEPEND="!!media-sound/alsa-headers"
-
-S=${WORKDIR}/gentoo-headers-base-${PV}
-
-src_unpack() {
- unpack ${A}
-}
-
-src_prepare() {
- [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
-}
-
-src_install() {
- kernel-2_src_install
-
- # hrm, build system sucks
- find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
- find "${ED}" -depth -type d -delete 2>/dev/null
-}
-
-src_test() {
- # Make sure no uapi/ include paths are used by accident.
- egrep -r \
- -e '# *include.*["<]uapi/' \
- "${D}" && die "#include uapi/xxx detected"
-
- einfo "Possible unescaped attribute/type usage"
- egrep -r \
- -e '(^|[[:space:](])(asm|volatile|inline)[[:space:](]' \
- -e '\<([us](8|16|32|64))\>' \
- .
-
- einfo "Missing linux/types.h include"
- egrep -l -r -e '__[us](8|16|32|64)' "${ED}" | xargs grep -L linux/types.h
-
- emake ARCH=$(tc-arch-kernel) headers_check
-}