summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-22 04:06:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-22 05:37:03 +0100
commit3ebe51048926cc82ee9b50f5fc46d51a5c45bd21 (patch)
tree990e0afb7de3688d84841b12ba5d162cb3d57239 /sys-kernel/vanilla-kernel
parentwww-client/seamonkey: fix dropping Rust upper bound (diff)
downloadgentoo-3ebe51048926cc82ee9b50f5fc46d51a5c45bd21.tar.gz
gentoo-3ebe51048926cc82ee9b50f5fc46d51a5c45bd21.tar.bz2
gentoo-3ebe51048926cc82ee9b50f5fc46d51a5c45bd21.zip
sys-kernel/vanilla-kernel: Bump to 6.0.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel/vanilla-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-6.0.15.ebuild134
2 files changed, 136 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index abb072e39ec3..faea6d791dfd 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -36,3 +36,5 @@ DIST linux-6.0.13.tar.sign 989 BLAKE2B 381ccfa7cb46511df7b42ca2fd4f97dc209b91beb
DIST linux-6.0.13.tar.xz 133926352 BLAKE2B b37026b1cab3079507ff80de9a32c753552689d30fb13898b9b7dd419dfb73785259976ad13fc08b5085b71ca94b84f40b5caf236b13b435c37a3736d64130da SHA512 6a1287077c7078e9a1bed5401e2eec7dc68cd0a278f6fbe2041a3e92fe005d2a21d251e7daade68ddaa7b303615ea40f0cb7aa702c1535327f4220088b95994d
DIST linux-6.0.14.tar.sign 989 BLAKE2B 1e1898dbc31fe96eaf0c58d62a07115a28522e7b5fde9510f138ec0e7873f25bc84bd097e529d40bdf4eb908916747570e2b575118de3930cc5092656e916cb3 SHA512 03a67b2195a42edc818861b66e5ad5ff37fbe6056047e5695cd02c83e4a0ba270fa2a13b4994a6034c0e69553399fd570c69f4817b75f10fcde75f17aafdc143
DIST linux-6.0.14.tar.xz 133938728 BLAKE2B 95adb29df31e257d1bbc0d01b7e908e08a1ab6643fa0e5a185e728629da86a88e6f8d1269f77bc64206dda3d4af10dfb186366c40e108566c87cf43fd05a3555 SHA512 4a409d18bb5c1bf0807a1670ae9a72984fc7df6b0c0fb3289b88eaf6a7d8456fc8481f8e9f4688fa9d27c4a1d85df61323e2bd5b1e534a3b64940aa9eb0dde80
+DIST linux-6.0.15.tar.sign 989 BLAKE2B 214ba7092718635f5dd39f2374615854c276e450ee81b8811b2e5a9dcff300eb38c4acbda4ebc1dcc0d7a2866e4a6bea8c2e5280309428164df8294bc616f8b3 SHA512 f39bebbb1d60ab7457e861ac7005a5cb975cb53519d777ff66119d2ca087f9a654cf1f11ecb4f7b58af6da574c698dccc69c9daa99ded277da178593c5fdaf76
+DIST linux-6.0.15.tar.xz 133929584 BLAKE2B 2d01f57c447ad7eecaa77a9b245ab1a79a35bdcede9d0b234dafd96d383a14a878868a6872d9c24cbc1a6a1332ccdeb15b492724063423ee833ccc56f9c5348d SHA512 1db7e086aaceabf12749728f100842c68886158202250cd9a582083488ee7073bc925f933f44b5c70a8f8c5bea48c73462da9ba979ef696005f16031d11312f6
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-6.0.15.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-6.0.15.ebuild
new file mode 100644
index 000000000000..d2f94947b12d
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-6.0.15.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit kernel-build toolchain-funcs verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+# forked to https://github.com/projg2/fedora-kernel-config-for-gentoo
+CONFIG_VER=6.0.8-gentoo
+GENTOO_CONFIG_VER=g3
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+="
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-aarch64-fedora.config
+ -> kernel-aarch64-fedora.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-ppc64le-fedora.config
+ -> kernel-ppc64le-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug hardened"
+REQUIRED_USE="arm? ( savedconfig )"
+
+BDEPEND="
+ debug? ( dev-util/pahole )
+ verify-sig? ( sec-keys/openpgp-keys-kernel )
+"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ local biendian=false
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm)
+ return
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ hppa)
+ return
+ ;;
+ ppc)
+ # assume powermac/powerbook defconfig
+ # we still package.use.force savedconfig
+ cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local myversion="-dist"
+ use hardened && myversion+="-hardened"
+ echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
+ local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
+
+ local merge_configs=(
+ "${T}"/version.config
+ "${dist_conf_path}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${dist_conf_path}"/no-debug.config
+ )
+ if use hardened; then
+ merge_configs+=( "${dist_conf_path}"/hardened-base.config )
+
+ tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
+
+ if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
+ merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
+ fi
+ fi
+
+ # this covers ppc64 and aarch64_be only for now
+ if [[ ${biendian} == true && $(tc-endian) == big ]]; then
+ merge_configs+=( "${dist_conf_path}/big-endian.config" )
+ fi
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}