summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-12-10 20:49:05 -0500
committerSam James <sam@gentoo.org>2024-05-08 16:06:14 +0100
commit8f5822dc5a81d773b77bbe2a7b16ceed74177607 (patch)
treebd98b38e100b7c64fca82223aa60ea528829f23b /sys-libs/compiler-rt
parentsys-devel/gcc: backport fix for Emacs tests to 14.1.0 (diff)
downloadgentoo-8f5822dc5a81d773b77bbe2a7b16ceed74177607.tar.gz
gentoo-8f5822dc5a81d773b77bbe2a7b16ceed74177607.tar.bz2
gentoo-8f5822dc5a81d773b77bbe2a7b16ceed74177607.zip
sys-libs/compiler-rt: replace "-emain" with "-e main" for LLVM 18
In the latest LLVM 18 snapshot, the joined form of the entrypoint argument (e.g. "-emain") was removed. Use "-e main" instead of "-emain" in nolib_flags. Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/34228 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild b/sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild
index e2a452caad61..2a724ca7dd8c 100644
--- a/sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild
@@ -90,7 +90,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild b/sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild
index e2a452caad61..2a724ca7dd8c 100644
--- a/sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild
@@ -90,7 +90,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild
index 46de84f27ba9..ec82b06b9c24 100644
--- a/sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild
@@ -89,7 +89,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild b/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild
index 46de84f27ba9..ec82b06b9c24 100644
--- a/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild
@@ -89,7 +89,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild b/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild
index 46de84f27ba9..ec82b06b9c24 100644
--- a/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild
@@ -89,7 +89,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"