summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-06 23:15:04 -0400
committerSam James <sam@gentoo.org>2024-05-08 20:19:27 +0100
commit1dc4c0c194edad65536af4838326f7cb13307523 (patch)
treef9b5eceed9f2b23361e5119749cc1cf710296aa9 /sys-libs/libseccomp
parentdev-util/qbs: prevent auto-selecting Qt version (diff)
downloadgentoo-1dc4c0c194edad65536af4838326f7cb13307523.tar.gz
gentoo-1dc4c0c194edad65536af4838326f7cb13307523.tar.bz2
gentoo-1dc4c0c194edad65536af4838326f7cb13307523.zip
sys-libs/libseccomp: run elibtoolize in non-live ebuild
When building live, we always run eautoreconf. However, even in release mode we should still run elibtoolize to get important fixes -- such as the ones that pass through LTO sanity flags to the link phase. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild b/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
index 40a0c5635548..153293b5f8ca 100644
--- a/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
+++ b/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
@@ -20,7 +20,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
else
AUTOTOOLS_AUTO_DEPEND=no
- inherit autotools
+ inherit autotools libtool
SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz
experimental-loong? ( https://github.com/matoro/libseccomp/compare/v${PV}..loongarch-r1.patch
-> ${P}-loongarch-r1.patch )"
@@ -78,6 +78,8 @@ src_prepare() {
if [[ ${PV} == *9999 ]] || use experimental-loong; then
rm -f "include/seccomp.h" || die
eautoreconf
+ else
+ elibtoolize
fi
}