summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-04 04:01:02 +0000
committerSam James <sam@gentoo.org>2023-01-04 04:31:58 +0000
commit910d028c7514d9547c1d6a716546eadc9707d86b (patch)
treec1b29a7a979ee149d20e0c98359f0775c16a0f07 /sys-libs/tdb/tdb-1.4.7-r1.ebuild
parentapp-crypt/efitools: drop 1.9.2 (diff)
downloadgentoo-910d028c7514d9547c1d6a716546eadc9707d86b.tar.gz
gentoo-910d028c7514d9547c1d6a716546eadc9707d86b.tar.bz2
gentoo-910d028c7514d9547c1d6a716546eadc9707d86b.zip
sys-libs/tdb: fix runtime w/ clang 16
Closes: https://bugs.gentoo.org/870043 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/tdb/tdb-1.4.7-r1.ebuild')
-rw-r--r--sys-libs/tdb/tdb-1.4.7-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sys-libs/tdb/tdb-1.4.7-r1.ebuild b/sys-libs/tdb/tdb-1.4.7-r1.ebuild
new file mode 100644
index 000000000000..791b32c1f197
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.4.7-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Simple database API"
+HOMEPAGE="https://tdb.samba.org/"
+SRC_URI="https://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/libcrypt"
+BDEPEND="${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.7-configure-clang16.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ export PYTHONHASHSEED=1
+}
+
+src_prepare() {
+ default
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python ; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+ use python && python_optimize
+}