summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-20 02:56:19 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-20 02:56:19 +0200
commit5b65f3d7e3ca9daa0831b09ecfdde854f152063d (patch)
tree13a00f0bd14231547ce09e3e18ea9a469cd2f228 /sys-libs/timezone-data
parentapp-metrics/collectd: bump to v5.9.0 (diff)
downloadgentoo-5b65f3d7e3ca9daa0831b09ecfdde854f152063d.tar.gz
gentoo-5b65f3d7e3ca9daa0831b09ecfdde854f152063d.tar.bz2
gentoo-5b65f3d7e3ca9daa0831b09ecfdde854f152063d.zip
sys-libs/timezone-data: fix paths for EAPI=7
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-libs/timezone-data')
-rw-r--r--sys-libs/timezone-data/timezone-data-2019b-r1.ebuild (renamed from sys-libs/timezone-data/timezone-data-2019b.ebuild)16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-libs/timezone-data/timezone-data-2019b.ebuild b/sys-libs/timezone-data/timezone-data-2019b-r1.ebuild
index 07d15cc49599..a52e4d3a7263 100644
--- a/sys-libs/timezone-data/timezone-data-2019b.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2019b-r1.ebuild
@@ -103,7 +103,7 @@ src_install() {
}
get_TIMEZONE() {
- local tz src="${EROOT}etc/timezone"
+ local tz src="${EROOT}/etc/timezone"
if [[ -e ${src} ]] ; then
tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${src}")
else
@@ -135,11 +135,11 @@ pkg_preinst() {
configure_tz_data() {
# make sure the /etc/localtime file does not get stale #127899
- local tz src="${EROOT}etc/timezone" etc_lt="${EROOT}etc/localtime"
+ local tz src="${EROOT}/etc/timezone" etc_lt="${EROOT}/etc/localtime"
# If it's a symlink, assume the user knows what they're doing and
# they're managing it themselves. #511474
- if [[ -L ${etc_lt} ]] ; then
+ if [[ -L "${etc_lt}" ]] ; then
einfo "Assuming your ${etc_lt} symlink is what you want; skipping update."
return 0
fi
@@ -148,10 +148,10 @@ configure_tz_data() {
einfo "Assuming your empty ${etc_lt} file is what you want; skipping update."
return 0
fi
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
+ if [[ "${tz}" == "FOOKABLOIE" ]] ; then
elog "You do not have TIMEZONE set in ${src}."
- if [[ ! -e ${etc_lt} ]] ; then
+ if [[ ! -e "${etc_lt}" ]] ; then
cp -f "${EROOT}"/usr/share/zoneinfo/Factory "${etc_lt}"
elog "Setting ${etc_lt} to Factory."
else
@@ -160,13 +160,13 @@ configure_tz_data() {
return 0
fi
- if [[ ! -e ${EROOT}/usr/share/zoneinfo/${tz} ]] ; then
+ if [[ ! -e "${EROOT}/usr/share/zoneinfo/${tz}" ]] ; then
elog "You have an invalid TIMEZONE setting in ${src}"
elog "Your ${etc_lt} has been reset to Factory; enjoy!"
tz="Factory"
fi
- einfo "Updating ${etc_lt} with ${EROOT}usr/share/zoneinfo/${tz}"
- cp -f "${EROOT}"/usr/share/zoneinfo/"${tz}" "${etc_lt}"
+ einfo "Updating ${etc_lt} with ${EROOT}/usr/share/zoneinfo/${tz}"
+ cp -f "${EROOT}/usr/share/zoneinfo/${tz}" "${etc_lt}"
}
pkg_config() {