summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-14 02:00:00 +0000
committerSam James <sam@gentoo.org>2024-01-14 02:00:00 +0000
commitcd28c4b9543d8c2823d8311635d4b50c0039d9d0 (patch)
tree93e8f915f1d166f6d92918c97bce91060068905b /sys-libs/zlib-ng
parentdev-util/byacc: add 20240109 (diff)
downloadgentoo-cd28c4b9543d8c2823d8311635d4b50c0039d9d0.tar.gz
gentoo-cd28c4b9543d8c2823d8311635d4b50c0039d9d0.tar.bz2
gentoo-cd28c4b9543d8c2823d8311635d4b50c0039d9d0.zip
sys-libs/zlib-ng: drop 2.1.3, 2.1.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/zlib-ng')
-rw-r--r--sys-libs/zlib-ng/Manifest2
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.1.3.ebuild86
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.1.4.ebuild86
3 files changed, 0 insertions, 174 deletions
diff --git a/sys-libs/zlib-ng/Manifest b/sys-libs/zlib-ng/Manifest
index 267262deb2b4..9fd23cff9381 100644
--- a/sys-libs/zlib-ng/Manifest
+++ b/sys-libs/zlib-ng/Manifest
@@ -1,3 +1 @@
-DIST zlib-ng-2.1.3.tar.gz 2404446 BLAKE2B f3c93e1ed6aa6d008915a69de92d58b1646fd41ae6c97fbdab9d921fd30c7931a42cf5dccd8911d52142960174a04df54d6ab557cc7c902930fc8609c31fbee9 SHA512 cb987c0b20a11fca5361dce94e53dead7364e739a984545c38ad4bf0c7fedd83d5d62530d979eca2182da88d7507a9bec8d3f5abff41e92ab5a63ac61001502e
-DIST zlib-ng-2.1.4.tar.gz 2408377 BLAKE2B 0b5aff9671b43bda2adfc84987c6baa108fa444978d465f12516f13f32b88e6bbe52f7d3e48ff93c720229842062fe71c38ff7c1e7591e18fc7351c943fd2a6b SHA512 5afda5ea4be84f7d7b016416a6eed18e2aab6c698f006cdfbc8f8b43ce3dc73c7994ab9d1ca090c1b93cb1aadc8747bfd8216afb22b44633d49127f01b77cfa2
DIST zlib-ng-2.1.5.tar.gz 2410601 BLAKE2B 7370ee38c05855e3a5e6976826690790adab7d68d877bf01f68969c99ad4a5fc8fd265a160e147b110969ff77ee97aab9c9d227a526d645a496eae76b2c27b04 SHA512 9212d87c63a2da4e5355a7a1c75380aeba40fbd0ea3d71d3784cb3eac94237f9bea2a1b7993a08f39d4197725c4c133087d3a9d213d3944aa48a7559de2be920
diff --git a/sys-libs/zlib-ng/zlib-ng-2.1.3.ebuild b/sys-libs/zlib-ng/zlib-ng-2.1.3.ebuild
deleted file mode 100644
index cfef9b1cc843..000000000000
--- a/sys-libs/zlib-ng/zlib-ng-2.1.3.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Worth keeping an eye on 'develop' branch upstream for possible backports,
-# as they copied this practice from sys-libs/zlib upstream.
-
-inherit cmake-multilib
-
-DESCRIPTION="Fork of the zlib data compression library"
-HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-CPU_USE=(
- x86_{avx2,avx512f,sse2,ssse3,sse4_2,pclmul}
- arm_{crc32,neon}
- ppc_{altivec,vsx2,vsx3}
-)
-IUSE="compat ${CPU_USE[@]/#/cpu_flags_} test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="compat? ( !sys-libs/zlib )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DZLIB_COMPAT=$(usex compat)
- -DZLIB_ENABLE_TESTS=$(usex test)
- -DWITH_GTEST=$(usex test)
-
- # Unaligned access is controversial and undefined behaviour
- # Let's keep it off for now
- # https://github.com/gentoo/gentoo/pull/17167
- -DWITH_UNALIGNED=OFF
- )
-
- # The intrinsics options are all defined conditionally, so we need
- # to enable them on/off per-arch here for now.
- # TODO: There's no s390x USE_EXPAND yet
- if use amd64 || use x86 ; then
- mycmakeargs+=(
- -DWITH_AVX2=$(usex cpu_flags_x86_avx2)
- -DWITH_AVX512=$(usex cpu_flags_x86_avx512f)
- -DWITH_AVX512VNNI=OFF # TODO, see bug #908556
- -DWITH_SSE2=$(usex cpu_flags_x86_sse2)
- -DWITH_SSSE3=$(usex cpu_flags_x86_ssse3)
- -DWITH_SSE42=$(usex cpu_flags_x86_sse4_2)
- -DWITH_PCLMULQDQ=$(usex cpu_flags_x86_pclmul)
- -DWITH_VPCLMULQDQ=OFF # TODO, see bug #908556
- )
- fi
-
- if use arm || use arm64 ; then
- mycmakeargs+=(
- -DWITH_ACLE=$(usex cpu_flags_arm_crc32)
- -DWITH_NEON=$(usex cpu_flags_arm_neon)
- )
- fi
-
- if use ppc || use ppc64 ; then
- # The POWER8 support is VSX which was introduced
- # VSX2 was introduced with POWER8, so use that as a proxy for it
- mycmakeargs+=(
- -DWITH_ALTIVEC=$(usex cpu_flags_ppc_altivec)
- -DWITH_POWER8=$(usex cpu_flags_ppc_vsx2)
- -DWITH_POWER9=$(usex cpu_flags_ppc_vsx3)
- )
- fi
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- if use compat ; then
- ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
- ewarn "Please be careful!"
- ewarn
- ewarn "The following link explains the guarantees (and what is NOT guaranteed):"
- ewarn "https://github.com/zlib-ng/zlib-ng/blob/2.0.x/PORTING.md"
- fi
-}
diff --git a/sys-libs/zlib-ng/zlib-ng-2.1.4.ebuild b/sys-libs/zlib-ng/zlib-ng-2.1.4.ebuild
deleted file mode 100644
index cfef9b1cc843..000000000000
--- a/sys-libs/zlib-ng/zlib-ng-2.1.4.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Worth keeping an eye on 'develop' branch upstream for possible backports,
-# as they copied this practice from sys-libs/zlib upstream.
-
-inherit cmake-multilib
-
-DESCRIPTION="Fork of the zlib data compression library"
-HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-CPU_USE=(
- x86_{avx2,avx512f,sse2,ssse3,sse4_2,pclmul}
- arm_{crc32,neon}
- ppc_{altivec,vsx2,vsx3}
-)
-IUSE="compat ${CPU_USE[@]/#/cpu_flags_} test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="compat? ( !sys-libs/zlib )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DZLIB_COMPAT=$(usex compat)
- -DZLIB_ENABLE_TESTS=$(usex test)
- -DWITH_GTEST=$(usex test)
-
- # Unaligned access is controversial and undefined behaviour
- # Let's keep it off for now
- # https://github.com/gentoo/gentoo/pull/17167
- -DWITH_UNALIGNED=OFF
- )
-
- # The intrinsics options are all defined conditionally, so we need
- # to enable them on/off per-arch here for now.
- # TODO: There's no s390x USE_EXPAND yet
- if use amd64 || use x86 ; then
- mycmakeargs+=(
- -DWITH_AVX2=$(usex cpu_flags_x86_avx2)
- -DWITH_AVX512=$(usex cpu_flags_x86_avx512f)
- -DWITH_AVX512VNNI=OFF # TODO, see bug #908556
- -DWITH_SSE2=$(usex cpu_flags_x86_sse2)
- -DWITH_SSSE3=$(usex cpu_flags_x86_ssse3)
- -DWITH_SSE42=$(usex cpu_flags_x86_sse4_2)
- -DWITH_PCLMULQDQ=$(usex cpu_flags_x86_pclmul)
- -DWITH_VPCLMULQDQ=OFF # TODO, see bug #908556
- )
- fi
-
- if use arm || use arm64 ; then
- mycmakeargs+=(
- -DWITH_ACLE=$(usex cpu_flags_arm_crc32)
- -DWITH_NEON=$(usex cpu_flags_arm_neon)
- )
- fi
-
- if use ppc || use ppc64 ; then
- # The POWER8 support is VSX which was introduced
- # VSX2 was introduced with POWER8, so use that as a proxy for it
- mycmakeargs+=(
- -DWITH_ALTIVEC=$(usex cpu_flags_ppc_altivec)
- -DWITH_POWER8=$(usex cpu_flags_ppc_vsx2)
- -DWITH_POWER9=$(usex cpu_flags_ppc_vsx3)
- )
- fi
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- if use compat ; then
- ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
- ewarn "Please be careful!"
- ewarn
- ewarn "The following link explains the guarantees (and what is NOT guaranteed):"
- ewarn "https://github.com/zlib-ng/zlib-ng/blob/2.0.x/PORTING.md"
- fi
-}