summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-29 09:39:11 +0100
committerSam James <sam@gentoo.org>2023-06-29 09:39:11 +0100
commitd9528533d6c6e83b02f01804b2b63b323f6346a9 (patch)
treeaf305061a1534756aa902837cf419edf9b9de8e4 /sys-libs/zlib-ng
parentmedia-libs/netpbm: Stabilize 11.2.0 hppa, #909360 (diff)
downloadgentoo-d9528533d6c6e83b02f01804b2b63b323f6346a9.tar.gz
gentoo-d9528533d6c6e83b02f01804b2b63b323f6346a9.tar.bz2
gentoo-d9528533d6c6e83b02f01804b2b63b323f6346a9.zip
sys-libs/zlib-ng: add 2.1.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/zlib-ng')
-rw-r--r--sys-libs/zlib-ng/Manifest1
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.1.3.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-libs/zlib-ng/Manifest b/sys-libs/zlib-ng/Manifest
index 6a7c819fb8e0..6680cee82115 100644
--- a/sys-libs/zlib-ng/Manifest
+++ b/sys-libs/zlib-ng/Manifest
@@ -1,2 +1,3 @@
DIST zlib-ng-2.0.7.tar.gz 853381 BLAKE2B 89672bd35ee54df72ff995c1b4ed188538011be4cd077e464f21a088b0b70b3f95b4259dc546a65e8d4900dc5bd5bb98041875e361000898b34518f7e008b99b SHA512 1c19a62bb00727ac49049c299fb70060da95b5fafa448144ae4133372ec8c3da15cef6c1303485290f269b23c580696554ca0383dba3e1f9609f65c332981988
DIST zlib-ng-2.1.2.tar.gz 2404176 BLAKE2B bc0b65520562827b10216110e2020a3341ee0dd853874c19ddb6f9df776fc74a542c1239f77dc3ec2ccb3f92e75f1de7ef104edfecfe37312149b1bc29ae7403 SHA512 2b3073df4eb13d8318f8fa2b7674e4729642488f65dad49d3080ccd830f29e9e3f32a673b42634443ddf9e9ef85cfff4f2f3e182506f950b9ee0a208a92c0465
+DIST zlib-ng-2.1.3.tar.gz 2404446 BLAKE2B f3c93e1ed6aa6d008915a69de92d58b1646fd41ae6c97fbdab9d921fd30c7931a42cf5dccd8911d52142960174a04df54d6ab557cc7c902930fc8609c31fbee9 SHA512 cb987c0b20a11fca5361dce94e53dead7364e739a984545c38ad4bf0c7fedd83d5d62530d979eca2182da88d7507a9bec8d3f5abff41e92ab5a63ac61001502e
diff --git a/sys-libs/zlib-ng/zlib-ng-2.1.3.ebuild b/sys-libs/zlib-ng/zlib-ng-2.1.3.ebuild
new file mode 100644
index 000000000000..cfef9b1cc843
--- /dev/null
+++ b/sys-libs/zlib-ng/zlib-ng-2.1.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Worth keeping an eye on 'develop' branch upstream for possible backports,
+# as they copied this practice from sys-libs/zlib upstream.
+
+inherit cmake-multilib
+
+DESCRIPTION="Fork of the zlib data compression library"
+HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+CPU_USE=(
+ x86_{avx2,avx512f,sse2,ssse3,sse4_2,pclmul}
+ arm_{crc32,neon}
+ ppc_{altivec,vsx2,vsx3}
+)
+IUSE="compat ${CPU_USE[@]/#/cpu_flags_} test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="compat? ( !sys-libs/zlib )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DZLIB_COMPAT=$(usex compat)
+ -DZLIB_ENABLE_TESTS=$(usex test)
+ -DWITH_GTEST=$(usex test)
+
+ # Unaligned access is controversial and undefined behaviour
+ # Let's keep it off for now
+ # https://github.com/gentoo/gentoo/pull/17167
+ -DWITH_UNALIGNED=OFF
+ )
+
+ # The intrinsics options are all defined conditionally, so we need
+ # to enable them on/off per-arch here for now.
+ # TODO: There's no s390x USE_EXPAND yet
+ if use amd64 || use x86 ; then
+ mycmakeargs+=(
+ -DWITH_AVX2=$(usex cpu_flags_x86_avx2)
+ -DWITH_AVX512=$(usex cpu_flags_x86_avx512f)
+ -DWITH_AVX512VNNI=OFF # TODO, see bug #908556
+ -DWITH_SSE2=$(usex cpu_flags_x86_sse2)
+ -DWITH_SSSE3=$(usex cpu_flags_x86_ssse3)
+ -DWITH_SSE42=$(usex cpu_flags_x86_sse4_2)
+ -DWITH_PCLMULQDQ=$(usex cpu_flags_x86_pclmul)
+ -DWITH_VPCLMULQDQ=OFF # TODO, see bug #908556
+ )
+ fi
+
+ if use arm || use arm64 ; then
+ mycmakeargs+=(
+ -DWITH_ACLE=$(usex cpu_flags_arm_crc32)
+ -DWITH_NEON=$(usex cpu_flags_arm_neon)
+ )
+ fi
+
+ if use ppc || use ppc64 ; then
+ # The POWER8 support is VSX which was introduced
+ # VSX2 was introduced with POWER8, so use that as a proxy for it
+ mycmakeargs+=(
+ -DWITH_ALTIVEC=$(usex cpu_flags_ppc_altivec)
+ -DWITH_POWER8=$(usex cpu_flags_ppc_vsx2)
+ -DWITH_POWER9=$(usex cpu_flags_ppc_vsx3)
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if use compat ; then
+ ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
+ ewarn "Please be careful!"
+ ewarn
+ ewarn "The following link explains the guarantees (and what is NOT guaranteed):"
+ ewarn "https://github.com/zlib-ng/zlib-ng/blob/2.0.x/PORTING.md"
+ fi
+}