summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-28 10:41:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-28 10:41:03 +0100
commit85e0c20c96c6260e927eef41fe0aae42fcf11cb6 (patch)
tree14f24936bb42a358e57d7cda080df612f37c86f1 /sys-libs
parentsys-process/glances: rebvump 3.1.3, fix tests, disable update check (diff)
downloadgentoo-85e0c20c96c6260e927eef41fe0aae42fcf11cb6.tar.gz
gentoo-85e0c20c96c6260e927eef41fe0aae42fcf11cb6.tar.bz2
gentoo-85e0c20c96c6260e927eef41fe0aae42fcf11cb6.zip
sys-libs/libcap: Don't remove libpsx.a or -lpsx fails for consumers
Attempt to fix build with LTO Bug: https://bugs.gentoo.org/702516 Closes: https://bugs.gentoo.org/703912 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap/files/libcap-2.29-build-system-fixes.patch17
-rw-r--r--sys-libs/libcap/libcap-2.29-r1.ebuild (renamed from sys-libs/libcap/libcap-2.29.ebuild)4
2 files changed, 18 insertions, 3 deletions
diff --git a/sys-libs/libcap/files/libcap-2.29-build-system-fixes.patch b/sys-libs/libcap/files/libcap-2.29-build-system-fixes.patch
index 910163c2612a..a7751f429fd5 100644
--- a/sys-libs/libcap/files/libcap-2.29-build-system-fixes.patch
+++ b/sys-libs/libcap/files/libcap-2.29-build-system-fixes.patch
@@ -1,4 +1,4 @@
-From 449b6cb6226086c136dd108d11471d99692812b7 Mon Sep 17 00:00:00 2001
+From 907626b63794199163778761fb56a5c89aa33e35 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Wed, 10 Feb 2016 09:47:27 +0100
Subject: [PATCH] build system fixes
@@ -21,11 +21,12 @@ Forward ported from libcap-2.28 to libcap-2.29
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
---
Make.Rules | 27 +++++++++++++++------------
+ Makefile | 1 -
libcap/Makefile | 7 ++++---
pam_cap/Makefile | 8 +++++---
progs/Makefile | 2 +-
tests/Makefile | 8 +++++---
- 5 files changed, 30 insertions(+), 22 deletions(-)
+ 6 files changed, 30 insertions(+), 23 deletions(-)
diff --git a/Make.Rules b/Make.Rules
index e7641e7..32c57df 100644
@@ -82,6 +83,18 @@ index e7641e7..32c57df 100644
ifeq ($(GOLANG),yes)
GOROOT := $(shell go env GOROOT)
GOCGO := $(shell if [ "$(shell go env CGO_ENABLED)" = 1 ]; then echo yes ; else echo no ; fi)
+diff --git a/Makefile b/Makefile
+index 14e29ef..f0104e0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,7 +16,6 @@ endif
+ ifeq ($(GOLANG),yes)
+ $(MAKE) -C go $@
+ endif
+- $(MAKE) -C tests $@
+ $(MAKE) -C progs $@
+ $(MAKE) -C doc $@
+ $(MAKE) -C kdebug $@
diff --git a/libcap/Makefile b/libcap/Makefile
index 949cfad..a7f80ce 100644
--- a/libcap/Makefile
diff --git a/sys-libs/libcap/libcap-2.29.ebuild b/sys-libs/libcap/libcap-2.29-r1.ebuild
index 567940f4c716..baec266531ef 100644
--- a/sys-libs/libcap/libcap-2.29.ebuild
+++ b/sys-libs/libcap/libcap-2.29-r1.ebuild
@@ -64,7 +64,9 @@ multilib_src_install() {
gen_usr_ldscript -a cap
if ! use static-libs ; then
- rm "${ED}"/usr/$(get_libdir)/lib{cap,psx}.a || die
+ # Don't remove libpsx.a!
+ # See https://bugs.gentoo.org/703912
+ rm "${ED}"/usr/$(get_libdir)/libcap.a || die
fi
if [[ -d "${ED}"/usr/$(get_libdir)/security ]] ; then