summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 13:47:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-03 08:04:08 +0200
commitf51d8525dc6850b01616424147ba5d06c7f7d78a (patch)
tree8d9ee80ec5bf6a48cded7c30b775ba5dc1d6fb34 /sys-libs
parentsys-libs/compiler-rt-sanitizers: Ensure NDEBUG correctly (diff)
downloadgentoo-f51d8525dc6850b01616424147ba5d06c7f7d78a.tar.gz
gentoo-f51d8525dc6850b01616424147ba5d06c7f7d78a.tar.bz2
gentoo-f51d8525dc6850b01616424147ba5d06c7f7d78a.zip
sys-libs/libomp: Ensure NDEBUG correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libomp/libomp-13.0.0.9999.ebuild5
-rw-r--r--sys-libs/libomp/libomp-13.0.0.ebuild5
-rw-r--r--sys-libs/libomp/libomp-14.0.0.9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/sys-libs/libomp/libomp-13.0.0.9999.ebuild b/sys-libs/libomp/libomp-13.0.0.9999.ebuild
index 5adaa0dfbcac..bf8f376ce98f 100644
--- a/sys-libs/libomp/libomp-13.0.0.9999.ebuild
+++ b/sys-libs/libomp/libomp-13.0.0.9999.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://openmp.llvm.org"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
KEYWORDS=""
-IUSE="cuda hwloc kernel_linux offload ompt test"
+IUSE="cuda debug hwloc kernel_linux offload ompt test"
# CUDA works only with the x86_64 ABI
REQUIRED_USE="offload? ( cuda? ( abi_x86_64 ) )"
RESTRICT="!test? ( test )"
@@ -66,6 +66,9 @@ pkg_setup() {
}
multilib_src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local libdir="$(get_libdir)"
local mycmakeargs=(
-DOPENMP_LIBDIR_SUFFIX="${libdir#lib}"
diff --git a/sys-libs/libomp/libomp-13.0.0.ebuild b/sys-libs/libomp/libomp-13.0.0.ebuild
index 136466d1b9a9..db94fb5536f1 100644
--- a/sys-libs/libomp/libomp-13.0.0.ebuild
+++ b/sys-libs/libomp/libomp-13.0.0.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://openmp.llvm.org"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
-IUSE="cuda hwloc kernel_linux offload ompt test"
+IUSE="cuda debug hwloc kernel_linux offload ompt test"
# CUDA works only with the x86_64 ABI
REQUIRED_USE="offload? ( cuda? ( abi_x86_64 ) )"
RESTRICT="!test? ( test )"
@@ -67,6 +67,9 @@ pkg_setup() {
}
multilib_src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local libdir="$(get_libdir)"
local mycmakeargs=(
-DOPENMP_LIBDIR_SUFFIX="${libdir#lib}"
diff --git a/sys-libs/libomp/libomp-14.0.0.9999.ebuild b/sys-libs/libomp/libomp-14.0.0.9999.ebuild
index 5adaa0dfbcac..bf8f376ce98f 100644
--- a/sys-libs/libomp/libomp-14.0.0.9999.ebuild
+++ b/sys-libs/libomp/libomp-14.0.0.9999.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://openmp.llvm.org"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
KEYWORDS=""
-IUSE="cuda hwloc kernel_linux offload ompt test"
+IUSE="cuda debug hwloc kernel_linux offload ompt test"
# CUDA works only with the x86_64 ABI
REQUIRED_USE="offload? ( cuda? ( abi_x86_64 ) )"
RESTRICT="!test? ( test )"
@@ -66,6 +66,9 @@ pkg_setup() {
}
multilib_src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local libdir="$(get_libdir)"
local mycmakeargs=(
-DOPENMP_LIBDIR_SUFFIX="${libdir#lib}"