summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDivagar Mohandass <m.divagar@gmail.com>2020-07-09 02:42:36 +0530
committerMatt Turner <mattst88@gentoo.org>2020-07-09 00:03:44 -0700
commit0662bbd1eaed9d7308522f099d244f829dcdcfd8 (patch)
tree16e365c83ac7b2e646816f047db2043cd27a35dc /sys-power/powertop
parentdev-perl/DBICx-TestDatabase: -r bump for EAPI7 + minor fixes (diff)
downloadgentoo-0662bbd1eaed9d7308522f099d244f829dcdcfd8.tar.gz
gentoo-0662bbd1eaed9d7308522f099d244f829dcdcfd8.tar.bz2
gentoo-0662bbd1eaed9d7308522f099d244f829dcdcfd8.zip
sys-power/powertop: Version bump to 2.13
Closes: https://github.com/gentoo/gentoo/pull/16642 Signed-off-by: Divagar Mohandass <m.divagar@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-power/powertop')
-rw-r--r--sys-power/powertop/Manifest1
-rw-r--r--sys-power/powertop/powertop-2.13.ebuild118
-rw-r--r--sys-power/powertop/powertop-9999.ebuild4
3 files changed, 121 insertions, 2 deletions
diff --git a/sys-power/powertop/Manifest b/sys-power/powertop/Manifest
index f033f60ac948..88069afa218d 100644
--- a/sys-power/powertop/Manifest
+++ b/sys-power/powertop/Manifest
@@ -1,2 +1,3 @@
DIST powertop-2.11.tar.gz 307755 BLAKE2B 01723262922df5cc2ec63f6972b2a301f7efc4c701dfa3c08280dcdaa4b79f2d04503592f8c17e43d77df89e7f08695b0381f498671969fe4aa388578f732978 SHA512 bbe2882196f1b3ae39885d38dd86018576bfac5b5e8f16ea10c7dfd197197d0493ae4ce83c969417a4c4239c41dbcfada989063f14e2943c088a7489e43953b7
+DIST powertop-2.13.tar.gz 303030 BLAKE2B 3c88e05f9889cc4b276bea3bc50a3a83228ca8efae278379a14fadc6104754f2837174e028bf9c5ded9f3af84ce6b8766ac3d24b6ae62b9b192c03fc3afdec11 SHA512 8ebeccd17b6f76d9e445382d9ce5b1c00ab2daf4f1e6e133c249bceb35ea582ca3e76da5415fd0b55a28b8a124655dc5ac7a18aaf2a3df955547d77495e59181
DIST powertop-v2.10.tar.gz 722992 BLAKE2B 573f1f0ed40705d3463f6e6f76c67ae99127ab2541b851143dafa707ef1c2dab4127d27811b63ad27e6b002ea4efd39417297a0227996ad9b01141b6de733d41 SHA512 4219e7aadbeebdf6932c04f784434e4dd0f540bf4941d43c1830b1b5cad1f3928769b13897e24dd956b6bdee65fb1fbe902ee30685bca229b71e140d65367837
diff --git a/sys-power/powertop/powertop-2.13.ebuild b/sys-power/powertop/powertop-2.13.ebuild
new file mode 100644
index 000000000000..3037572fdbe8
--- /dev/null
+++ b/sys-power/powertop/powertop-2.13.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/fenrus75/powertop.git"
+
+if [[ ${PV} == "9999" ]] ; then
+ GIT_ECLASS="git-r3"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/fenrus75/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools ${GIT_ECLASS} linux-info
+
+DESCRIPTION="tool to diagnose issues with power consumption and power management"
+HOMEPAGE="https://01.org/powertop/ https://github.com/fenrus75/powertop/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls unicode X"
+
+DEPEND="
+ dev-libs/libnl:3
+ sys-apps/pciutils
+ sys-libs/ncurses:=[unicode?]
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.20.2
+"
+RDEPEND="
+ ${DEPEND}
+ X? ( x11-apps/xset )
+ virtual/libintl
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.8-ncurses_tinfo.patch
+)
+
+pkg_setup() {
+ CONFIG_CHECK="
+ ~X86_MSR
+ ~DEBUG_FS
+ ~PERF_EVENTS
+ ~TRACEPOINTS
+ ~NO_HZ_IDLE
+ ~HIGH_RES_TIMERS
+ ~HPET_TIMER
+ ~CPU_FREQ_STAT
+ ~CPU_FREQ_GOV_ONDEMAND
+ ~FTRACE
+ ~BLK_DEV_IO_TRACE
+ ~TRACING
+ "
+ ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_NO_HZ_IDLE="NO_HZ_IDLE should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
+ ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable other config options"
+ ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ if kernel_is -lt 3 7 0; then
+ if linux_chkconfig_present SND_HDA_INTEL; then
+ CONFIG_CHECK="~SND_HDA_POWER_SAVE"
+ ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ fi
+ if kernel_is -lt 3 9 0; then
+ CONFIG_CHECK="~EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ if kernel_is -lt 3 19; then
+ CONFIG_CHECK="~PM_RUNTIME"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ check_extra_config
+ else
+ CONFIG_CHECK="~PM"
+ ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ if kernel_is -lt 4 11; then
+ CONFIG_CHECK="~TIMER_STATS"
+ ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Bug 599114
+ sed -i '1s|^|AX_REQUIRE_DEFINED([AX_CXX_COMPILE_STDCXX])|' configure.ac || die
+
+ echo "\"${PV}\"" > version-short
+ echo "${PV}" > version-long
+
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
+ econf $(use_enable nls)
+}
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 39fc48dc78de..b6c21806001a 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,7 +30,7 @@ DEPEND="
BDEPEND="
virtual/pkgconfig
- sys-devel/gettext
+ >=sys-devel/gettext-0.20.2
"
RDEPEND="
${DEPEND}