summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-08 05:20:14 +0000
committerSam James <sam@gentoo.org>2023-01-08 05:20:14 +0000
commitfa4a7949b8a7168452519d798f190a18f7b4593a (patch)
treeeb7359cb8ffda8557995a450dd8f5dd1b7767ed0 /sys-process/atop
parentsys-process/atop: add 2.8.1 (diff)
downloadgentoo-fa4a7949b8a7168452519d798f190a18f7b4593a.tar.gz
gentoo-fa4a7949b8a7168452519d798f190a18f7b4593a.tar.bz2
gentoo-fa4a7949b8a7168452519d798f190a18f7b4593a.zip
sys-process/atop: drop 2.8.0
2.8.1 contains a bunch of crash fixes over 2.8.0. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/atop')
-rw-r--r--sys-process/atop/Manifest1
-rw-r--r--sys-process/atop/atop-2.8.0.ebuild112
2 files changed, 0 insertions, 113 deletions
diff --git a/sys-process/atop/Manifest b/sys-process/atop/Manifest
index b685890a9d16..7f2dc7e6b946 100644
--- a/sys-process/atop/Manifest
+++ b/sys-process/atop/Manifest
@@ -1,4 +1,3 @@
DIST atop-2.7.1.tar.gz 248809 BLAKE2B 2cf1a68a7b24d76340295d9bde03a5602e9049a860468217771c696fe4b9062f2155aeefa2e3e810984780f82de6bf922bf7d6b02c7fd19194162dc70b015b81 SHA512 18f30c67d6f86b9270599317eed846c63d19e8ba6ea85bad8ec3d5ffb0489f17c75c8d8b3a14054bd14e89ed40d39e5d37bce834c7422087e6d8b86c99273a72
-DIST atop-2.8.0.tar.gz 263650 BLAKE2B 88ec63d482d34866d82d16f1c60a4a04bc749014f22f991ec9e6233a5d63a12b5a9c637544e27e346f751466c636d3b365bce5fc65f62e7bf9224faa9be047e9 SHA512 f601bdabc33f581e85b9b753537bddbeb4dd2a2cd9eec8716d856c7766e489b419eaf15c1b2fd2c1a2a64628d459e113739b939fc06f5d33828b22a9550c76fa
DIST atop-2.8.1.tar.gz 264182 BLAKE2B 1764090d760cc8d75d193a077776a269eaa4ba997e8e5f064525d23f2005b92bb1b3f0903f2b1476f437db6a0dc698575e95b34e0fc9112d2ff6d06d3133ea78 SHA512 d748f374fb66d7ce33cebc5ce6899c3c0cc79dc394cb835466b21c7a4ec7c17cba255a3b04b36136c8c24c33ced0e5bd68f151ac804f6176547399e457976aaf
DIST netatop-3.1.tar.gz 22812 BLAKE2B 1b1faebf1392a57db6b4662192f90821289c8fc40c2c1ee0ad61feeeee6477c4d091744a1e82cdd987baf59f8dd71fc6d242d6dd294b8fb29b9447a9d5055996 SHA512 b12fd2287d89d3a8277f8fb540a19e6d26aa26c3f88e7ae2e6601b63f78d642e73b8d16cf351f6979ce7bbf53251b9c1faa76798a87f70cf3dcf51279eb0db68
diff --git a/sys-process/atop/atop-2.8.0.ebuild b/sys-process/atop/atop-2.8.0.ebuild
deleted file mode 100644
index 960cbc056e3f..000000000000
--- a/sys-process/atop/atop-2.8.0.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Check on bumps of atop
-# https://www.atoptool.nl/downloadnetatop.php
-NETATOP_VER=3.1
-
-# Controls 'netatop' kernel module
-MODULES_OPTIONAL_USE="modules"
-NETATOP_P=net${PN}-${NETATOP_VER}
-NETATOP_S="${WORKDIR}"/${NETATOP_P}
-
-inherit linux-info linux-mod systemd toolchain-funcs
-
-DESCRIPTION="Resource-specific view of processes"
-HOMEPAGE="https://www.atoptool.nl/ https://github.com/Atoptool/atop"
-SRC_URI="https://github.com/Atoptool/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" modules? ( https://www.atoptool.nl/download/${NETATOP_P}.tar.gz )"
-
-# Module is GPL-2 as well
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="sys-libs/ncurses:0=
- >=sys-process/acct-6.6.4-r1
- modules? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.6.0-build.patch
-)
-
-pkg_pretend() {
- if use kernel_linux ; then
- CONFIG_CHECK="~BSD_PROCESS_ACCT"
- check_extra_config
- fi
-}
-
-src_prepare() {
- default
-
- if use modules ; then
- cd "${WORKDIR}"/${NETATOP_P} || die
- eapply -p1 "${FILESDIR}"/${PN}-2.7.0-netatop-makefile.patch
- cd "${S}" || die
- fi
-
- tc-export CC PKG_CONFIG
-
- # bug #191926
- sed -i 's: root : :' atop.cronsysv || die
-
- # prefixify
- sed -i "s:/\(usr\|etc\|var\):${EPREFIX}/\1:g" Makefile || die
-}
-
-src_configure() {
- default
-
- BUILD_TARGETS="netatop.ko"
- MODULE_NAMES="netatop(:${NETATOP_S}/module)"
-}
-
-src_compile() {
- default
-
- linux-mod_src_compile
-}
-
-src_install() {
- linux-mod_src_install
-
- if use modules ; then
- # netatop's Makefile tries to build the kernel module for us
- # so let's just replicate parts of it here.
- emake -C "${NETATOP_S}"/daemon all
-
- dosbin "${NETATOP_S}"/daemon/netatopd
- doman "${NETATOP_S}"/man/*
-
- systemd_dounit "${NETATOP_S}"/netatop.service
-
- # TODO: Release after 2.8.0 may contain this, check!
- newinitd "${FILESDIR}"/netatop.rc netatop
- fi
-
- emake DESTDIR="${D}" genericinstall
-
- # useless -${PV} copies ?
- rm "${ED}"/usr/bin/atop*-${PV} || die
-
- newinitd atop.rc.openrc ${PN}
- newinitd atopacct.rc.openrc atopacct
-
- systemd_dounit "${S}"/${PN}.service
- systemd_dounit "${S}"/atopacct.service
-
- dodoc atop.cronsysv AUTHORS README
-
- exeinto /usr/share/${PN}
- doexe ${PN}.daily
-
- insinto /etc/default
- newins ${PN}{.default,}
-
- keepdir /var/log/${PN}
-}