summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandy Barlow <randy@electronsweatshop.com>2024-07-25 19:04:31 -0400
committerJoonas Niilola <juippis@gentoo.org>2024-08-14 15:35:02 +0300
commit3ddf613f90eb6a36ac8231aaab3b0a4ec7af2ce5 (patch)
tree57998fff3c5b6865ba40a912021819101128e8ec /virtual
parentdev-lang/rust: Add 1.80.1 (diff)
downloadgentoo-3ddf613f90eb6a36ac8231aaab3b0a4ec7af2ce5.tar.gz
gentoo-3ddf613f90eb6a36ac8231aaab3b0a4ec7af2ce5.tar.bz2
gentoo-3ddf613f90eb6a36ac8231aaab3b0a4ec7af2ce5.zip
virtual/rust: Add 1.80.1
Signed-off-by: Randy Barlow <randy@electronsweatshop.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/rust/rust-1.80.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.80.1.ebuild b/virtual/rust/rust-1.80.1.ebuild
new file mode 100644
index 000000000000..89d91522025f
--- /dev/null
+++ b/virtual/rust/rust-1.80.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-18"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt profiler"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+)"