summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-07-19 13:39:45 +0800
committerWANG Xuerui <xen0n@gentoo.org>2023-07-20 17:48:27 +0800
commitc12b1a7b68d60225302c4e0c9e95c1c9f6c939c5 (patch)
tree5f8979b2f29525d24aa763cfaefb9093d340a421 /virtual
parentdev-lang/rust: add 1.71.0 (diff)
downloadgentoo-c12b1a7b68d60225302c4e0c9e95c1c9f6c939c5.tar.gz
gentoo-c12b1a7b68d60225302c4e0c9e95c1c9f6c939c5.tar.bz2
gentoo-c12b1a7b68d60225302c4e0c9e95c1c9f6c939c5.zip
virtual/rust: add 1.71.0
Bug: https://bugs.gentoo.org/910496 Closes: https://github.com/gentoo/gentoo/pull/31241 Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/rust/rust-1.71.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.71.0.ebuild b/virtual/rust/rust-1.71.0.ebuild
new file mode 100644
index 000000000000..55d0ba31f086
--- /dev/null
+++ b/virtual/rust/rust-1.71.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-16"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"