summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_tcl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_tcl')
-rw-r--r--www-apache/mod_tcl/Manifest1
-rw-r--r--www-apache/mod_tcl/files/27_mod_tcl.conf7
-rw-r--r--www-apache/mod_tcl/metadata.xml5
-rw-r--r--www-apache/mod_tcl/mod_tcl-1.0.1.ebuild31
4 files changed, 44 insertions, 0 deletions
diff --git a/www-apache/mod_tcl/Manifest b/www-apache/mod_tcl/Manifest
new file mode 100644
index 000000000000..b801629d0ee4
--- /dev/null
+++ b/www-apache/mod_tcl/Manifest
@@ -0,0 +1 @@
+DIST mod_tcl-1.0.1.tar.bz2 18772 SHA256 b1e5b859707d1a81e7588c35fbe1f69fefa4cada04da20048b80269ed43101dd SHA512 d32a722115079696bef6b88a295a25cc752552d0d6ceb598ba1bcbf54151fb5dbfe192f8f2e9f7f31ba2cf0ad9f09b09967b00ae03c478453a497118ecaedaff WHIRLPOOL c73916c6d6d0e36975a9ad30fee2e020da2cd5ac3b391f727025ea634eb58597c282f7f1f71d1c951646f0ae9196d9c490315d45d97843b656ef6df0dc786e43
diff --git a/www-apache/mod_tcl/files/27_mod_tcl.conf b/www-apache/mod_tcl/files/27_mod_tcl.conf
new file mode 100644
index 000000000000..801702b37892
--- /dev/null
+++ b/www-apache/mod_tcl/files/27_mod_tcl.conf
@@ -0,0 +1,7 @@
+<IfDefine TCL>
+LoadModule tcl_module modules/mod_tcl.so
+
+# See http://tcl.apache.org/mod_tcl/ for now :/
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_tcl/metadata.xml b/www-apache/mod_tcl/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_tcl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild b/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild
new file mode 100644
index 000000000000..6bbb9db3b915
--- /dev/null
+++ b/www-apache/mod_tcl/mod_tcl-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+DESCRIPTION="An Apache2 module providing an embedded Tcl interpreter"
+HOMEPAGE="http://tcl.apache.org/mod_tcl/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="Apache-1.1"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-lang/tcl"
+RDEPEND="${DEPEND}"
+
+APXS2_ARGS="-c -Wl,-ltcl -DHAVE_TCL_H ${PN}.c tcl_cmds.c tcl_misc.c"
+
+APACHE2_MOD_CONF="27_${PN}"
+APACHE2_MOD_DEFINE="TCL"
+
+DOCFILES="AUTHORS INSTALL NEWS README test_script.tm"
+
+need_apache2_2
+
+src_compile() {
+ mv -f "tcl_core.c" "${PN}.c" || die
+ apache-module_src_compile
+}