summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2017-11-19 20:50:33 +0100
committerDirkjan Ochtman <djc@gentoo.org>2017-11-19 20:50:52 +0100
commit376971b384e5b2a4de122de95052bed2b030eaa9 (patch)
tree7f875f92b5faac8ad801e2a23f921fda3a79a71d /www-apache/mod_wsgi/mod_wsgi-4.5.21.ebuild
parentwww-apache/mod_wsgi: remove old versions (diff)
downloadgentoo-376971b384e5b2a4de122de95052bed2b030eaa9.tar.gz
gentoo-376971b384e5b2a4de122de95052bed2b030eaa9.tar.bz2
gentoo-376971b384e5b2a4de122de95052bed2b030eaa9.zip
www-apache/mod_wsgi: version bump to 4.5.21
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'www-apache/mod_wsgi/mod_wsgi-4.5.21.ebuild')
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-4.5.21.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/mod_wsgi-4.5.21.ebuild b/www-apache/mod_wsgi/mod_wsgi-4.5.21.ebuild
new file mode 100644
index 000000000000..0cea82a06698
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-4.5.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+PYTHON_REQ_USE="threads"
+
+inherit apache-module eutils python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+src_configure() {
+ econf --with-apxs=${APXS} --with-python=${PYTHON}
+}
+
+src_compile() {
+ default
+}