summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/pwauth/pwauth-2.3.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/pwauth/pwauth-2.3.10.ebuild')
-rw-r--r--www-apache/pwauth/pwauth-2.3.10.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/www-apache/pwauth/pwauth-2.3.10.ebuild b/www-apache/pwauth/pwauth-2.3.10.ebuild
new file mode 100644
index 000000000000..e19a28810691
--- /dev/null
+++ b/www-apache/pwauth/pwauth-2.3.10.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base flag-o-matic pam toolchain-funcs
+
+DESCRIPTION="A Unix Web Authenticator"
+HOMEPAGE="http://code.google.com/p/pwauth/"
+SRC_URI="http://pwauth.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="faillog pam ignore-case domain-aware"
+
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-config.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${PN}-strchr.patch"
+)
+
+pkg_setup() {
+ einfo "You can configure various build time options with ENV variables:"
+ einfo
+ einfo " PWAUTH_FAILLOG Path to logfile for login failures"
+ einfo " (default: /var/log/pwauth.log)"
+ einfo " PWAUTH_SERVERUIDS Comma seperated list of UIDs allowed to run pwauth"
+ einfo " (default: 81)"
+ einfo " PWAUTH_MINUID Minimum UID for which authentication will succeed"
+ einfo " (default: 1000)"
+ einfo
+
+ PWAUTH_FAILLOG="${PWAUTH_FAILLOG:-/var/log/pwauth.log}"
+ PWAUTH_SERVERUIDS="${PWAUTH_SERVERUIDS:-81}"
+ PWAUTH_MINUID="${PWAUTH_MINUID:-1000}"
+
+ append-cflags "-DSERVER_UIDS=${PWAUTH_SERVERUIDS}"
+ append-cflags "-DMIN_UNIX_UID=${PWAUTH_MINUID}"
+
+ if use faillog; then
+ append-cflags -DFAILLOG_PWAUTH
+ append-cflags "-DPATH_FAILLOG=\"\\\"${PWAUTH_FAILLOG}\\\"\""
+ fi
+
+ if use pam; then
+ append-cflags -DPAM
+ append-libs pam
+ else
+ append-cflags -DSHADOW_SUN
+ append-libs crypt
+ fi
+
+ use ignore-case && append-cflags -DIGNORE_CASE
+ use domain-aware && append-cflags -DOMAIN_AWARE
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin pwauth unixgroup
+ fperms 4755 /usr/sbin/pwauth
+
+ use pam && newpamd "${FILESDIR}"/pwauth.pam-include pwauth
+
+ dodoc CHANGES FORM_AUTH INSTALL README
+}