summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/egroupware
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/egroupware')
-rw-r--r--www-apps/egroupware/Manifest3
-rw-r--r--www-apps/egroupware/egroupware-1.8.004.20120613.ebuild81
-rw-r--r--www-apps/egroupware/files/postinstall-en-1.2.txt12
-rw-r--r--www-apps/egroupware/metadata.xml12
4 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/egroupware/Manifest b/www-apps/egroupware/Manifest
new file mode 100644
index 000000000000..c7fb48e154d3
--- /dev/null
+++ b/www-apps/egroupware/Manifest
@@ -0,0 +1,3 @@
+DIST eGroupware-1.8.004.20120613.tar.bz2 10460480 SHA256 63cab7d7dd02c56164fd4670ade765b18d9cbdf3e0a1834025216a651c170c54 SHA512 9b4c953e830d651951e019c3bfed399f9c3e846a819757fba832e6b491626f45fa93142d351f697fc72d5b3e7f1cb2c5353e8f726d30e671b5ef67b01a543402 WHIRLPOOL 7eccfe874597bdc8ec0d3480e3d9c3d1980abb9390f6a7fa8c281603920a188d72fd19be6e6200f03fa133ca1b34353c2d1398bb7378626d9a25dea5496f5b75
+DIST eGroupware-egw-pear-1.8.004.20120613.tar.bz2 75148 SHA256 19ec4e94b24535b5d988dcffdecb922c3b2b63524abd6623f90c690cba51e2e4 SHA512 25e5cacb0e8a19290c3a708f7c77e64458ebd4332bf9a0f95f45db1d144ad0a73253049049206b990543f9194e43b509b0bd94a0179ccbbada4f4567730061d8 WHIRLPOOL 5f980eae9d09fe7a7c7813e7736bc0ae1e3ac88d9ddb54c86b3e44316106f0dacf6b0996e924085301f21d38ef22e64cd1046b7176854d7b2ab045c941c531b8
+DIST eGroupware-gallery-1.8.004.20120613.tar.bz2 10508030 SHA256 a49e1309a3ad8bc1de319fcb93ee8f3696b64ad14ebb44fc5a3efaf77ac437fa SHA512 03eaa49c0dfc309e1d17757a84f45f692ef55cd762f4f049ddd9c22b8ff9a70eb30411607a439a0ea09ec81b545858f657a429bfa81157fc222f44503068fab3 WHIRLPOOL 034d1a9eb673b2a497985327126179d123975a3a73142a8b8024226cd462d5556f5a57999e49e5a459569030afecbf28eb463a781ada34215bee2431e1b639f9
diff --git a/www-apps/egroupware/egroupware-1.8.004.20120613.ebuild b/www-apps/egroupware/egroupware-1.8.004.20120613.ebuild
new file mode 100644
index 000000000000..1f8d067d54f6
--- /dev/null
+++ b/www-apps/egroupware/egroupware-1.8.004.20120613.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils webapp
+
+MY_PN=eGroupware
+
+DESCRIPTION="Web-based GroupWare suite"
+HOMEPAGE="http://www.egroupware.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.bz2
+ mirror://sourceforge/${PN}/${MY_PN}-egw-pear-${PV}.tar.bz2
+ gallery? ( mirror://sourceforge/${PN}/${MY_PN}-gallery-${PV}.tar.bz2 )"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ppc ~sparc x86"
+IUSE="+jpgraph ldap mysql postgres gallery"
+
+# php deps taken from rpm spec
+# you can use pdo to access almost anything but sqlite is specifically required
+# for the calendar module
+# jpgraph is only needed for the projectmanager module
+RDEPEND="jpgraph? ( dev-php/jpgraph )
+ dev-php/pear
+ dev-php/PEAR-Auth_SASL
+ virtual/httpd-php
+ dev-lang/php[gd,imap,pdo,posix,session,sqlite,ssl,unicode,xml,zip,zlib,ldap?,mysql?,postgres?]
+ virtual/cron"
+
+REQUIRED_USE="|| ( mysql postgres )"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ esvn_clean
+
+ if use jpgraph; then
+ einfo "Fixing jpgraph location"
+ MY_JPGRAPH_VERSION="$(best_version dev-php/jpgraph)"
+ MY_JPGRAPH_VERSION="${MY_JPGRAPH_VERSION/'dev-php/jpgraph-'/}"
+ sed -i "s|EGW_SERVER_ROOT . '/../jpgraph/src/jpgraph.php'|'/usr/share/php/jpgraph/jpgraph.php'|" \
+ projectmanager/inc/class.projectmanager_ganttchart.inc.php || die "sed jpgraph failed"
+ sed -i "s|EGW_SERVER_ROOT . '/../jpgraph/src/jpgraph_gantt.php'|'/usr/share/php/jpgraph/jpgraph_gantt.php'|" \
+ projectmanager/inc/class.projectmanager_ganttchart.inc.php || die "sed jpgraph failed"
+ sed -i "s|$jpgraph_path .= SEP.'jpgraph';|$jpgraph_path = dirname('/usr/share/php/jpgraph/jpgraph.php');|" \
+ setup/check_install.php || die "sed jpgraph failed"
+ sed -i "s|'unknown';|'${MY_JPGRAPH_VERSION}';\n \$available = version_compare(\$version,\$min_version,'>=');|" \
+ setup/check_install.php || die "sed jpgraph failed"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc doc/rpm-build/egroupware.cron
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}/phpgwapi/images"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.2.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ if use ldap; then
+ elog "If you are using LDAP contacts/addressbook, please read the upgrade instructions at"
+ elog "http://www.egroupware.org/index.php?page_name=wiki&wikipage=ManualSetupUpdate"
+ elog "before running the egroupware setup"
+ fi
+
+ elog "A cronjob to run eGroupware's async services is available at"
+ elog "/usr/share/doc/${P}"
+
+ webapp_pkg_postinst
+}
diff --git a/www-apps/egroupware/files/postinstall-en-1.2.txt b/www-apps/egroupware/files/postinstall-en-1.2.txt
new file mode 100644
index 000000000000..eadc25dbc7f7
--- /dev/null
+++ b/www-apps/egroupware/files/postinstall-en-1.2.txt
@@ -0,0 +1,12 @@
+You are almost done!
+
+0. Restart your webserver and your database daemon.
+
+1. Point your browser to the URL http://${VHOST_HOSTNAME}/egroupware/setup
+and follow the install/upgrade script.
+
+Don't forget to read the installation manual, available from
+http://community.egroupware.org/index.php?page_name=wiki&lang=&wikipage=ManualSetupCheck_install
+It describes the rest of the installation process.
+
+Enjoy eGroupWare!
diff --git a/www-apps/egroupware/metadata.xml b/www-apps/egroupware/metadata.xml
new file mode 100644
index 000000000000..93bdf0b618bc
--- /dev/null
+++ b/www-apps/egroupware/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <use>
+ <flag name="jpgraph">Add <pkg>dev-php/jpgraph</pkg> support</flag>
+ <flag name="gallery">Install gallery2 port for eGW</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">egroupware</remote-id>
+ </upstream>
+</pkgmetadata>