summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-07-11 16:28:46 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-11 17:46:01 +0200
commit4c01d03e99ef4954e69d6a944b890d3107fdd2ec (patch)
treecd73ed31e57857ac4db7c2dc4ca864c78ea48620 /www-apps/kibana-bin
parentwww-client/qutebrowser: bump 1.4.1 (diff)
downloadgentoo-4c01d03e99ef4954e69d6a944b890d3107fdd2ec.tar.gz
gentoo-4c01d03e99ef4954e69d6a944b890d3107fdd2ec.tar.bz2
gentoo-4c01d03e99ef4954e69d6a944b890d3107fdd2ec.zip
www-apps/kibana-bin: bump to 5.6.10
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'www-apps/kibana-bin')
-rw-r--r--www-apps/kibana-bin/Manifest1
-rw-r--r--www-apps/kibana-bin/kibana-bin-5.6.10.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/www-apps/kibana-bin/Manifest b/www-apps/kibana-bin/Manifest
index 2013a0cb63a8..a5041c12cc4c 100644
--- a/www-apps/kibana-bin/Manifest
+++ b/www-apps/kibana-bin/Manifest
@@ -1,3 +1,4 @@
+DIST kibana-5.6.10-linux-x86_64.tar.gz 52586941 BLAKE2B cb4e1716c640c80be980541e5496a96fc6baa04152e11f754b46dc71a9995809038b8a82c3404d9d86d1bd0381e9fc55fca44c66f046cb41e005c760aa077092 SHA512 c56c600c79bf2f5d2991d6c1442db300c78dd4135bf8dec5b9f500d609e2f041d09649195cfdae2f6d30cf8de2c2c865ac607283f865c4aa8ec1d400af84c270
DIST kibana-5.6.9-linux-x86_64.tar.gz 52381284 BLAKE2B 962891ada991f718bb3a1445ec369db0e71e27aa76fb0170d57dfa66ea2b3e14289412464ec6c6b687e09fb3cad77a7900985dbcbd7fb29e103b06ba6cc8aa9c SHA512 e30fd6735b5fa510b81ba70a66faf2ff57ea01bcc0b0379607173d7a8cef44628efcaa0bd055b3f6672f7874c616c0d99b353a0e14d354879a9675fd367676fa
DIST kibana-6.2.2-linux-x86_64.tar.gz 83415765 BLAKE2B 86f7511c82b6954a8769673b856eb46f2b633490535a013d4e30138e8abee470776493de43284f2e68b2cac6b74ba2b76245fd35803b8b5834f79ea5f488dd6b SHA512 8d26eb8293028aa0c35942a7b5025401f9b717d5c548d6cdbcf2761c0d8cc1189fdbf12c6f39468d4c809a3975f5f3c817e0f02424b296ce36183e118b0c72c6
DIST kibana-6.2.4-linux-x86_64.tar.gz 85348919 BLAKE2B ce062a5a7d96c0266143f1091f7dbe5ade6236068a73f6fedbe253957f7ddf2d00b441d985f72e9936aa3bfa7ecd9e7b7672b301b726a7d78c3e2b71d52c3b24 SHA512 125c2002e1a3b197f9f0d6200f2979f2e5974a902bfec2baa4b34a0c8d55babccafdb87b8a7b69c61ca4c02b8ae97e69b9b2743f7d445f0e53e31c69288296d5
diff --git a/www-apps/kibana-bin/kibana-bin-5.6.10.ebuild b/www-apps/kibana-bin/kibana-bin-5.6.10.ebuild
new file mode 100644
index 000000000000..3a61facff7bb
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-5.6.10.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver user
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Analytics and search dashboard for Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="net-libs/nodejs"
+
+S="${WORKDIR}/${MY_P}-linux-x86_64"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
+}
+
+src_prepare() {
+ default
+
+ # remove bundled nodejs
+ rm -r node || die
+
+ # remove empty unused directory
+ rmdir data || die
+}
+
+src_install() {
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -r config || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}
+
+ insinto /opt/${MY_PN}
+ doins -r .
+
+ chmod +x "${ED%/}"/opt/${MY_PN}/bin/* || die
+
+ diropts -m 0750 -o ${MY_PN} -g ${MY_PN}
+ keepdir /var/log/${MY_PN}
+}
+
+pkg_postinst() {
+ elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2) and"
+ elog "Node.js 6. Some plugins may fail with other versions of Node.js (Bug #656008)."
+ elog
+ elog "Be sure to point ES_INSTANCE to your Elasticsearch instance"
+ elog "in /etc/conf.d/${MY_PN}."
+ elog
+ elog "Elasticsearch can run local or remote."
+}