summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 19:41:10 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 21:24:33 +0100
commit3130542ee6a805690df481dca7756fd3c2cafc92 (patch)
tree409a8d8601b80a9a83efdec4891a7ca69daa5343 /www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
parentwww-apps/trac-tags: distutils-r1, EAPI=6 (diff)
downloadgentoo-3130542ee6a805690df481dca7756fd3c2cafc92.tar.gz
gentoo-3130542ee6a805690df481dca7756fd3c2cafc92.tar.bz2
gentoo-3130542ee6a805690df481dca7756fd3c2cafc92.zip
www-apps/trac-mercurial: distutils-r1, EAPI=6
Diffstat (limited to 'www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild')
-rw-r--r--www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild b/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
new file mode 100644
index 000000000000..6989df50ac58
--- /dev/null
+++ b/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 mercurial
+
+MY_PN="TracMercurial"
+MY_P="${MY_PN}-${PV/_pre/dev-r}"
+
+DESCRIPTION="A Mercurial plugin for Trac"
+HOMEPAGE="http://trac.edgewall.org/"
+EHG_REPO_URI="https://hg.edgewall.org/trac/mercurial-plugin"
+EHG_REVISION="8df754d9b36a"
+
+LICENSE="GPL-2"
+SLOT="0"
+# KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=www-apps/trac-1.0[${PYTHON_USEDEP}]
+ >=dev-vcs/mercurial-1.1[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"