summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-05 00:22:34 +0100
committerSam James <sam@gentoo.org>2022-05-05 00:22:45 +0100
commit13fb5b0bd1ed64c3a5910ad2e29459f60c377547 (patch)
tree93f5c84d5cf98bebcf9a41a55cc3c266d3c31c15 /www-apps
parentwww-apps/gitea: security bump to 1.16.7 (diff)
downloadgentoo-13fb5b0bd1ed64c3a5910ad2e29459f60c377547.tar.gz
gentoo-13fb5b0bd1ed64c3a5910ad2e29459f60c377547.tar.bz2
gentoo-13fb5b0bd1ed64c3a5910ad2e29459f60c377547.zip
www-apps/gitea: rebase PIE changes onto 1.16.7
Bug: https://bugs.gentoo.org/832756 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/gitea-1.16.7.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/www-apps/gitea/gitea-1.16.7.ebuild b/www-apps/gitea/gitea-1.16.7.ebuild
index eaeda1a3f382..249baa6f0eb7 100644
--- a/www-apps/gitea/gitea-1.16.7.ebuild
+++ b/www-apps/gitea/gitea-1.16.7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit fcaps go-module tmpfiles systemd
+inherit fcaps go-module tmpfiles systemd flag-o-matic
DESCRIPTION="A painless self-hosted Git service"
HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
@@ -13,7 +13,7 @@ S="${WORKDIR}"
LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
SLOT="0"
-IUSE="+acct pam sqlite"
+IUSE="+acct pam sqlite pie"
DEPEND="
acct? (
@@ -52,6 +52,12 @@ src_prepare() {
fi
}
+src_configure() {
+ # bug 832756 - PIE build issues
+ filter-flags -fPIE
+ filter-ldflags -fPIE -pie
+}
+
src_compile() {
local gitea_tags=(
bindata
@@ -69,7 +75,12 @@ src_compile() {
TAGS="${gitea_tags[*]}"
)
- env "${makeenv[@]}" emake backend
+ GOFLAGS=""
+ if use pie ; then
+ GOFLAGS+="-buildmode=pie"
+ fi
+
+ env "${makeenv[@]}" emake EXTRA_GOFLAGS="${GOFLAGS}" backend
}
src_install() {