summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-06-18 15:52:06 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-06-23 16:27:45 +0300
commit199c8bda128fc93ba38502deba2e2b4bd951ce77 (patch)
treed8eb1e9749c45f55fbb85b373e103304682e317e /www-apps
parentmedia-video/mpv: update live (diff)
downloadgentoo-199c8bda128fc93ba38502deba2e2b4bd951ce77.tar.gz
gentoo-199c8bda128fc93ba38502deba2e2b4bd951ce77.tar.bz2
gentoo-199c8bda128fc93ba38502deba2e2b4bd951ce77.zip
www-apps/hugo: add 0.127.0
Signed-off-by: tastytea <gentoo@tastytea.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.127.0.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index c6c0bda69aef..c59368c9d16c 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -4,3 +4,5 @@ DIST hugo-0.125.4-vendor.tar.xz 6722504 BLAKE2B ceccdb09cb41d730e398664f0fae6406
DIST hugo-0.125.4.tar.gz 21063288 BLAKE2B 688feac45a0b9c5c7876d28e23b4e1412f4795e866bd1baa06a79f30fe482aea9f7f40a24088c9c252b2528036bd41f3a84c3cb61aa942cf5c56fd9249c000eb SHA512 f76b85e0cb119fa35b8c253ddb05c9f8156aba004b1ec37e0b04d89afa6dec3771417c843594d076c81b1663d0a7677912f9b37ab3ef89ae13824973e6496097
DIST hugo-0.125.7-vendor.tar.xz 6760028 BLAKE2B 8ced0fc2c9b5b7a73eb11c31e8d94ddc4fd150508ababc2252e5456f3bfb9bd27609551a703b5663eea8cbdc410153dddfde854137ed7ea703d2eb2637c0cdd5 SHA512 8bb2d0d872c86bd20408c593987b0cf28fea1969c85e7fecbe5a977b8775cc9c55aa3e0f7e548d6a879ad154394ac2fcc4ea1568e116e2d73f56b80ed6fc061e
DIST hugo-0.125.7.tar.gz 21062939 BLAKE2B 030171ac009c50e85123a3c4c3573da1b81a2696d2f98b51543fb5c28467d1f5416513dad278063590361ea1611735d41d514ce3226a222d32be6fb16e84630d SHA512 e6202026c7918f885abce338ade2e0a59d3a299030fc3b32af65eb434da31ef90647d14294ce1be5b3c66d2cd950b7a1f826094a2bf0e9538285e8cb2717cb91
+DIST hugo-0.127.0-vendor.tar.xz 6747376 BLAKE2B 28569618b1398effe5eeafe72b43576986a9680371100812b546c5c62936754ebc4ecda2c8fea77ec93761b5e3746509b065bd6e1000815135be31a8ba8077c8 SHA512 f88d7a98d2d012e48beb239941a0a485b3ac761b055c7e76b5823550275e19b4ced6977765a7cc34342c5e9113f208793f483794afefa9689c76b3b4dedca94f
+DIST hugo-0.127.0.tar.gz 21132608 BLAKE2B 6fa8ae09d325292715d94f28e13d3bce8efcecc5e729da3644a054857aa3e11893068bd25524857e7dde6bab92efc9acb5b0de823c8a6246b9f5e83b07c4e279 SHA512 829d118f12f153794ed882572a37ec2a3b3ade9c8160a754d3d411d6aede22c15e44dd75a52443e3cc7fc8ea1f65febecac5a47b4e09cc42006d7badd1a0fa2f
diff --git a/www-apps/hugo/hugo-0.127.0.ebuild b/www-apps/hugo/hugo-0.127.0.ebuild
new file mode 100644
index 000000000000..93b9e87528d4
--- /dev/null
+++ b/www-apps/hugo/hugo-0.127.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="doc +extended test"
+
+BDEPEND="
+ >=dev-lang/go-1.22.2
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ extended? (
+ dev-libs/libsass:=
+ >=media-libs/libwebp-1.3.2:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.121.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.123.0-skip-some-tests.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export MY_BUILD_FLAGS="$(usev extended "-tags extended")"
+
+ default
+}
+
+src_prepare() {
+ # wants to run command that require network access
+ rm testscripts/commands/mod{,_vendor,__disable,_get,_get_u,_npm{,_withexisting}}.txt || die
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test "./..." ${MY_BUILD_FLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+ dofishcomp completions/${PN}.fish
+ dozshcomp completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}
+
+pkg_postinst() {
+ elog "the sass USE-flag was renamed to extended. the functionality is the" \
+ "same, except it also toggles the dependency on libwebp (for encoding)"
+}