summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Shanks <mrpippy@gmail.com>2024-07-01 21:48:27 -0700
committerViorel Munteanu <ceamac@gentoo.org>2024-12-22 16:37:51 +0200
commitebefd241f38cffe5beef5ec273b644634ee0498e (patch)
treec41a343a5c7698c84822f0f06aec19dbbbcf8888 /www-apps
parentapp-backup/duplicity: stabilize 3.0.2 for amd64 (diff)
downloadgentoo-ebefd241f38cffe5beef5ec273b644634ee0498e.tar.gz
gentoo-ebefd241f38cffe5beef5ec273b644634ee0498e.tar.bz2
gentoo-ebefd241f38cffe5beef5ec273b644634ee0498e.zip
www-apps/mythweb: add 34.0
Closes: https://bugs.gentoo.org/643366 Signed-off-by: Brendan Shanks <mrpippy@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37395 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mythweb/Manifest1
-rw-r--r--www-apps/mythweb/mythweb-34.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/www-apps/mythweb/Manifest b/www-apps/mythweb/Manifest
index f8f550aed86f..298c5b5a099e 100644
--- a/www-apps/mythweb/Manifest
+++ b/www-apps/mythweb/Manifest
@@ -1 +1,2 @@
DIST mythweb-0.28.1.tar.gz 1705490 BLAKE2B 210f8c27471ea83e412ed9f37f72084e32a9d320eccc03b9abf01f89d272abbe036db5e019fd4af6677aa078827c2e3edd14cadd932d5ee8757cee2680239210 SHA512 0ce9e2c7138d35ef59859a8a8980b01d90d9b616e55653fb28dd5a473199446508e525171687383ce83051b434f5e7618f509a9e75cd84296446ee450733e963
+DIST mythweb-34.0.tar.gz 1797525 BLAKE2B cbc3f797356e7f53eebebc3e60376052c2511546de275468af0014505221846503624e6deee13ac2527460ef02cb938b1abd97368db717cfef0664b162bf5641 SHA512 d364512efc40d81532eb29164e707b7a7bc9902573f7a170e3bf1fa7973ba60374e11631c70003bf03efdce1c9dbc9a33b09b33b4df8535b4ddd8db10457aea6
diff --git a/www-apps/mythweb/mythweb-34.0.ebuild b/www-apps/mythweb/mythweb-34.0.ebuild
new file mode 100644
index 000000000000..6f6fcae78019
--- /dev/null
+++ b/www-apps/mythweb/mythweb-34.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+# Release version
+MY_PV="${PV%_p*}"
+MY_P="mythweb-${MY_PV}"
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
+HOMEPAGE="https://www.mythtv.org"
+SRC_URI="https://github.com/MythTV/mythweb/archive/v${MY_PV}.tar.gz -> mythweb-${MY_PV}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-lang/php:*[json(+),mysql,session,posix]
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ dev-perl/HTTP-Date
+ dev-perl/Net-UPnP
+ virtual/httpd-php:*
+"
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Install docs
+ cd "${S}" || die
+ dodoc README INSTALL
+
+ # Install htdocs files
+ insinto "${MY_HTDOCSDIR}"
+ doins mythweb.php
+ doins -r classes
+ doins -r configuration
+ doins -r data
+ doins -r includes
+ doins -r js
+ doins -r modules
+ doins -r skins
+ doins -r tests
+ exeinto "${MY_HTDOCSDIR}"
+ doexe mythweb.pl
+
+ # Install our server config files
+ webapp_server_configfile apache mythweb.conf.apache mythweb.conf
+ webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
+ webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
+ mythweb.include
+
+ # Data needs to be writable and modifiable by the web server
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+
+ # Message to display after install
+ webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
+
+ # Script to set the correct defaults on install
+ webapp_hook_script "${FILESDIR}"/reconfig
+
+ webapp_src_install
+}