summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-06 06:10:39 +0000
committerSam James <sam@gentoo.org>2022-11-06 06:14:40 +0000
commite78648c527124117d91118870084cf412e2fcad0 (patch)
treeb85c9b7153b85286ac0e2d373cc7db4c534d895b /www-client/microsoft-edge
parentdev-python/statsd: Bump to 4.0.0 (diff)
downloadgentoo-e78648c527124117d91118870084cf412e2fcad0.tar.gz
gentoo-e78648c527124117d91118870084cf412e2fcad0.tar.bz2
gentoo-e78648c527124117d91118870084cf412e2fcad0.zip
www-client/microsoft-edge: automated bump (107.0.1418.35)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/microsoft-edge')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-107.0.1418.35.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index d16a49b24ddd..38acae973109 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_106.0.1370.42-1_amd64.deb 136004156 BLAKE2B 238e1e4fd0873afb549565290b56edddc5621f0689a664ef91b5f47dda32368439ae075e41009edce912703074097ed8b8fc772db797562aa83606431cdf5429 SHA512 ecdb845d32b0336bcaa91f84a4d13a0aed2aa9df18dc163e82f839e506a248058a0899750c25b96839a79df31825e377d8812d7db4b84e6a030ddedc6a04f6d6
+DIST microsoft-edge-stable_107.0.1418.35-1_amd64.deb 134281434 BLAKE2B 185115629bcae6cd609b4ccf05deaf7647d86d855a41d7fbfcb07ce2b8960488b69eeb8b73c60b97faf2c6c4b7ce3a9b33ff620543e64fe595a6297dede75d15 SHA512 081730692b4361eb07e60952bc0dd6c36ee6f70e5445b0b37d7d307c08f3af2557a274f308cde54f95710187dc2cab8bb10024407c4f852e71fc36cc65c56246
diff --git a/www-client/microsoft-edge/microsoft-edge-107.0.1418.35.ebuild b/www-client/microsoft-edge/microsoft-edge-107.0.1418.35.ebuild
new file mode 100644
index 000000000000..873f8ce87360
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-107.0.1418.35.ebuild
@@ -0,0 +1,117 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+IUSE="+mip"
+
+RDEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ ( app-accessibility/at-spi2-atk dev-libs/atk )
+ )
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm -f _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}