summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormojyack <mojyack@gmail.com>2024-05-12 13:51:47 +0900
committerJoonas Niilola <juippis@gentoo.org>2024-05-13 09:48:39 +0300
commit6ecf3061626e43777c39a44594dba467a29b185b (patch)
treee104298dbe7feddd1790f13732a48280f01876c3 /www-client
parentwww-client/firefox: remove trailing whitespace in comment (diff)
downloadgentoo-6ecf3061626e43777c39a44594dba467a29b185b.tar.gz
gentoo-6ecf3061626e43777c39a44594dba467a29b185b.tar.bz2
gentoo-6ecf3061626e43777c39a44594dba467a29b185b.zip
www-client/firefox: support aarch64-unknown-linux-musl
Signed-off-by: mojyack <mojyack@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36647 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-115.10.0.ebuild2
-rw-r--r--www-client/firefox/firefox-115.9.0.ebuild2
-rw-r--r--www-client/firefox/firefox-115.9.1.ebuild2
-rw-r--r--www-client/firefox/firefox-125.0.2.ebuild2
-rw-r--r--www-client/firefox/firefox-125.0.3.ebuild2
5 files changed, 10 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-115.10.0.ebuild b/www-client/firefox/firefox-115.10.0.ebuild
index d5bbc0d6b106..0edc08563f46 100644
--- a/www-client/firefox/firefox-115.10.0.ebuild
+++ b/www-client/firefox/firefox-115.10.0.ebuild
@@ -693,6 +693,8 @@ src_prepare() {
export RUST_TARGET="x86_64-unknown-linux-musl"
elif use x86 ; then
export RUST_TARGET="i686-unknown-linux-musl"
+ elif use arm64 ; then
+ export RUST_TARGET="aarch64-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi
diff --git a/www-client/firefox/firefox-115.9.0.ebuild b/www-client/firefox/firefox-115.9.0.ebuild
index 331790eb878d..281dc76598dc 100644
--- a/www-client/firefox/firefox-115.9.0.ebuild
+++ b/www-client/firefox/firefox-115.9.0.ebuild
@@ -693,6 +693,8 @@ src_prepare() {
export RUST_TARGET="x86_64-unknown-linux-musl"
elif use x86 ; then
export RUST_TARGET="i686-unknown-linux-musl"
+ elif use arm64 ; then
+ export RUST_TARGET="aarch64-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi
diff --git a/www-client/firefox/firefox-115.9.1.ebuild b/www-client/firefox/firefox-115.9.1.ebuild
index d07acf7df8f4..731334c2bbdd 100644
--- a/www-client/firefox/firefox-115.9.1.ebuild
+++ b/www-client/firefox/firefox-115.9.1.ebuild
@@ -693,6 +693,8 @@ src_prepare() {
export RUST_TARGET="x86_64-unknown-linux-musl"
elif use x86 ; then
export RUST_TARGET="i686-unknown-linux-musl"
+ elif use arm64 ; then
+ export RUST_TARGET="aarch64-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi
diff --git a/www-client/firefox/firefox-125.0.2.ebuild b/www-client/firefox/firefox-125.0.2.ebuild
index 52b150e3f0ef..7c34e086a5d2 100644
--- a/www-client/firefox/firefox-125.0.2.ebuild
+++ b/www-client/firefox/firefox-125.0.2.ebuild
@@ -635,6 +635,8 @@ src_prepare() {
export RUST_TARGET="x86_64-unknown-linux-musl"
elif use x86 ; then
export RUST_TARGET="i686-unknown-linux-musl"
+ elif use arm64 ; then
+ export RUST_TARGET="aarch64-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi
diff --git a/www-client/firefox/firefox-125.0.3.ebuild b/www-client/firefox/firefox-125.0.3.ebuild
index 1fdcfca9cbe0..d2c697706ca3 100644
--- a/www-client/firefox/firefox-125.0.3.ebuild
+++ b/www-client/firefox/firefox-125.0.3.ebuild
@@ -631,6 +631,8 @@ src_prepare() {
export RUST_TARGET="x86_64-unknown-linux-musl"
elif use x86 ; then
export RUST_TARGET="i686-unknown-linux-musl"
+ elif use arm64 ; then
+ export RUST_TARGET="aarch64-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi