summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-04 16:33:56 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-04 16:36:23 +0200
commitd16d2717ec6e75c500dd429abf39e93bc1d58130 (patch)
treede11dbd3ca1f8aeec9ffcf9d70aa208e6b4e9ac3 /www-client
parentmedia-libs/libraw: Security cleanup (diff)
downloadgentoo-d16d2717ec6e75c500dd429abf39e93bc1d58130.tar.gz
gentoo-d16d2717ec6e75c500dd429abf39e93bc1d58130.tar.bz2
gentoo-d16d2717ec6e75c500dd429abf39e93bc1d58130.zip
www-client/firefox: don't pass -g* value from FLAGS when not using CLANG
Closes: https://bugs.gentoo.org/721126 Closes: https://bugs.gentoo.org/746506 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-78.3.1.ebuild6
-rw-r--r--www-client/firefox/firefox-81.0.1.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-78.3.1.ebuild b/www-client/firefox/firefox-78.3.1.ebuild
index 7393ac574e62..af2a9e59b726 100644
--- a/www-client/firefox/firefox-78.3.1.ebuild
+++ b/www-client/firefox/firefox-78.3.1.ebuild
@@ -566,7 +566,11 @@ src_configure() {
mozconfig_add_options_ac '+debug' --disable-optimize
else
if is-flag '-g*' ; then
- mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
+ if use clang ; then
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
+ else
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols
+ fi
else
mozconfig_add_options_ac 'Gentoo default' --disable-debug-symbols
fi
diff --git a/www-client/firefox/firefox-81.0.1.ebuild b/www-client/firefox/firefox-81.0.1.ebuild
index abcb74f221b4..b73b187b80cc 100644
--- a/www-client/firefox/firefox-81.0.1.ebuild
+++ b/www-client/firefox/firefox-81.0.1.ebuild
@@ -566,7 +566,11 @@ src_configure() {
mozconfig_add_options_ac '+debug' --disable-optimize
else
if is-flag '-g*' ; then
- mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
+ if use clang ; then
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
+ else
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols
+ fi
else
mozconfig_add_options_ac 'Gentoo default' --disable-debug-symbols
fi