summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-misc/urlwatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-misc/urlwatch')
-rw-r--r--www-misc/urlwatch/Manifest3
-rw-r--r--www-misc/urlwatch/metadata.xml15
-rw-r--r--www-misc/urlwatch/urlwatch-1.16.ebuild28
-rw-r--r--www-misc/urlwatch/urlwatch-1.17.ebuild28
-rw-r--r--www-misc/urlwatch/urlwatch-1.18.ebuild28
5 files changed, 102 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
new file mode 100644
index 000000000000..1c2b6843a71f
--- /dev/null
+++ b/www-misc/urlwatch/Manifest
@@ -0,0 +1,3 @@
+DIST urlwatch-1.16.tar.gz 14416 SHA256 2e382100d6c72e739fcf66712e775854bfb53a06c2f27ebe01d5719540aac179 SHA512 d9b918fb90c457d8167543107abf59feca2857bfcde8192f6740b29988fe2f27f330a49f2656f0b769c70ce3642a097d6cb7f98f56b1d167d691c15465770b9d WHIRLPOOL d58e72982267a78958e7321034fe4217f0ac92c7900e0c90cffe2686472264da7d2e069706a668ac23df470749a2431f79ec1ad63d3b35b53035371fd520dc19
+DIST urlwatch-1.17.tar.gz 14647 SHA256 006f04c124cf3dace3d071921e5ed452f6fbd463495bc8aa7879b915407c88f6 SHA512 67026913083fcc99e99cfb33a31873ac48a2ee69db34b8c13fcccc3bdd051787954cfbf3d3ef73a331c03540e254f53ba6d2661967f89de204798aaf35033cd0 WHIRLPOOL 0cade08f009e4c71c6bd8e554f9d6e34d44fa4ff18a3b91c78317599f8e3df62d9dbe3cedd75d8f85478ba8b893c4d36b69965c074312d0ea04fce8c8ca132f3
+DIST urlwatch-1.18.tar.gz 14987 SHA256 6b17411b6658f3aeb5839d1b32458f020ce40ee1e62a3d40387a2622fa731824 SHA512 ffbfb41e5b6ca71abf19132424dc1bfb3d0cfc30a644615c34539bb5b00acea5803d4c30637c58e9682820c5411227f7c579344c1e212f575431a1c650a7e520 WHIRLPOOL 49915ef83cc835b8ac67216eaeb61391195f28fa28b5716c7e1cc8c8dac465d9f3670beb408c80dc3fa5315683467524b02b1663fb671f26338059acfa247b23
diff --git a/www-misc/urlwatch/metadata.xml b/www-misc/urlwatch/metadata.xml
new file mode 100644
index 000000000000..0710a69773a9
--- /dev/null
+++ b/www-misc/urlwatch/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <maintainer>
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">urlwatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-misc/urlwatch/urlwatch-1.16.ebuild b/www-misc/urlwatch/urlwatch-1.16.ebuild
new file mode 100644
index 000000000000..8eeaecb8e5e1
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-1.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ http://pypi.python.org/pypi/urlwatch"
+SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ || ( www-client/lynx app-text/html2text )"
+
+python_prepare() {
+ if [[ ${EPYTHON} == python3.* ]]; then
+ 2to3 -nw --no-diffs urlwatch lib/urlwatch/*.py \
+ share/urlwatch/examples/hooks.py.example setup.py || die
+ fi
+}
diff --git a/www-misc/urlwatch/urlwatch-1.17.ebuild b/www-misc/urlwatch/urlwatch-1.17.ebuild
new file mode 100644
index 000000000000..96f5b76b45fa
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-1.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ http://pypi.python.org/pypi/urlwatch"
+SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ || ( www-client/lynx app-text/html2text )"
+
+python_prepare() {
+ if [[ ${EPYTHON} == python3.* ]]; then
+ 2to3 -nw --no-diffs urlwatch lib/urlwatch/*.py \
+ share/urlwatch/examples/hooks.py.example setup.py || die
+ fi
+}
diff --git a/www-misc/urlwatch/urlwatch-1.18.ebuild b/www-misc/urlwatch/urlwatch-1.18.ebuild
new file mode 100644
index 000000000000..8eeaecb8e5e1
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-1.18.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ http://pypi.python.org/pypi/urlwatch"
+SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ || ( www-client/lynx app-text/html2text )"
+
+python_prepare() {
+ if [[ ${EPYTHON} == python3.* ]]; then
+ 2to3 -nw --no-diffs urlwatch lib/urlwatch/*.py \
+ share/urlwatch/examples/hooks.py.example setup.py || die
+ fi
+}