summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-plugins/kaffeine-mozilla-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-plugins/kaffeine-mozilla-plugin')
-rw-r--r--www-plugins/kaffeine-mozilla-plugin/Manifest1
-rw-r--r--www-plugins/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2-r1.ebuild34
-rw-r--r--www-plugins/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild34
-rw-r--r--www-plugins/kaffeine-mozilla-plugin/metadata.xml9
4 files changed, 78 insertions, 0 deletions
diff --git a/www-plugins/kaffeine-mozilla-plugin/Manifest b/www-plugins/kaffeine-mozilla-plugin/Manifest
new file mode 100644
index 000000000000..b56fc942611b
--- /dev/null
+++ b/www-plugins/kaffeine-mozilla-plugin/Manifest
@@ -0,0 +1 @@
+DIST kaffeine-mozilla-0.2.tar.bz2 223559 SHA256 10cdc4019d8a6babb350a5b8ca184631c9e0c33bc03c4163d272dfaf1c2155bb SHA512 e3e0b2d23b7a2b21181e1b88445936dcced3244f60099447e2d7a4fd46d0e2ba4127ae051dfe548e5de3756beb7188886c2e86e322ab09d085847e584762d6e8 WHIRLPOOL e303d22bae1460ea9ae2b73f47e3c5c4fa3518e0048a2d847c10dd8c0e497fd5d649add0ecd92b8bc2edf785a47f2924cffce05e23ac7ccf4da22b0e9e5a8239
diff --git a/www-plugins/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2-r1.ebuild b/www-plugins/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2-r1.ebuild
new file mode 100644
index 000000000000..5f25b84d19c1
--- /dev/null
+++ b/www-plugins/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib nsplugins
+
+MY_P=${P/-plugin/}
+
+DESCRIPTION="The Kaffeine Mozilla starter plugin"
+HOMEPAGE="http://kaffeine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kaffeine/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+RDEPEND="${DEPEND}
+ media-video/kaffeine"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ emake prefix="${D}"/usr/$(get_libdir)/${PLUGINS_DIR%plugins} install
+ dodoc AUTHORS ChangeLog README
+ prune_libtool_files --modules
+}
diff --git a/www-plugins/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild b/www-plugins/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild
new file mode 100644
index 000000000000..ac539a1504e6
--- /dev/null
+++ b/www-plugins/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit nsplugins multilib
+
+MY_P=${P/-plugin/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="The Kaffeine Mozilla starter plugin"
+HOMEPAGE="http://kaffeine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kaffeine/${MY_P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND=">=media-video/kaffeine-0.4.3
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf \
+ --prefix=/usr/$(get_libdir)/${PLUGINS_DIR}
+ --libdir=/usr/$(get_libdir)/${PLUGINS_DIR%plugins}
+
+ emake || die
+}
+
+src_install() {
+ einstall prefix="${D}"/usr/$(get_libdir)/${PLUGINS_DIR%plugins} || die
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/www-plugins/kaffeine-mozilla-plugin/metadata.xml b/www-plugins/kaffeine-mozilla-plugin/metadata.xml
new file mode 100644
index 000000000000..62c56c83007a
--- /dev/null
+++ b/www-plugins/kaffeine-mozilla-plugin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="sourceforge">kaffeine</remote-id>
+ </upstream>
+</pkgmetadata>