summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-05-31 23:12:15 +0200
committerSam James <sam@gentoo.org>2022-06-11 06:18:16 +0100
commit12d029caa52f79fe86bd4eaef19d0e446df443ed (patch)
tree4e73d0594183cd8804b9e02e86de8bd938c93abf /www-servers
parentwww-servers/pound: fix build with musl (diff)
downloadgentoo-12d029caa52f79fe86bd4eaef19d0e446df443ed.tar.gz
gentoo-12d029caa52f79fe86bd4eaef19d0e446df443ed.tar.bz2
gentoo-12d029caa52f79fe86bd4eaef19d0e446df443ed.zip
www-servers/pound: add 3.0.2
Add an ebuild for pound-3.0.2 with support for EAPI 8. Closes: https://bugs.gentoo.org/837992 Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/Manifest1
-rw-r--r--www-servers/pound/files/pound-3.0.2-hpack.patch21
-rw-r--r--www-servers/pound/pound-3.0.2.ebuild56
3 files changed, 78 insertions, 0 deletions
diff --git a/www-servers/pound/Manifest b/www-servers/pound/Manifest
index 5e80194f89a2..9c988692f43e 100644
--- a/www-servers/pound/Manifest
+++ b/www-servers/pound/Manifest
@@ -1 +1,2 @@
+DIST Pound-3.0.2.tgz 76000 BLAKE2B 0e3f2dc69771a1d1f3de00a721f02cdc4ff31f4d17ab81f64c368668f03c0c1f12484e2d40e7c1d2d203b033488f2bad57cafd8da5022dfe680a09cdc6b73bec SHA512 4c96a93df2b340049778ed7782377e521fbdd7b6ccaa157748b05941ac7a825b2688f37f3081a7e577b2fa1ec4f64d68a25d27af2210f59da5be0dc10d1391e9
DIST Pound-3.0.tgz 75905 BLAKE2B 8834d2d57c81bf792d803bc2aef7ad5d17243539ea3fddab777ab3dbd7f903a2f771762ee8d4818c63b7c6380c253dc7c7465e10225f884c2bb968af3dfab831 SHA512 28426fa2d66efa310fce43fc57b87b6cd9d646573161ab880b139feec856710306002af623f023907bb77f8b37979cf2332dc3e16cde48c6d349d813c6ac47e2
diff --git a/www-servers/pound/files/pound-3.0.2-hpack.patch b/www-servers/pound/files/pound-3.0.2-hpack.patch
new file mode 100644
index 000000000000..d413082216ab
--- /dev/null
+++ b/www-servers/pound/files/pound-3.0.2-hpack.patch
@@ -0,0 +1,21 @@
+--- a/src/hpack.c
++++ b/src/hpack.c
+@@ -69,9 +69,6 @@ static size_t hbuf_left(struct hbuf *);
+
+ static struct hpack hpack_global;
+
+-#ifdef __GLIBC__
+-/* these functions are available on BSD, but not on Linux */
+-
+ #include <stdlib.h>
+
+ void *
+@@ -100,8 +97,6 @@ freezero(void *ptr, size_t size)
+ return;
+ }
+
+-#endif
+-
+ int
+ hpack_init(void)
+ {
diff --git a/www-servers/pound/pound-3.0.2.ebuild b/www-servers/pound/pound-3.0.2.ebuild
new file mode 100644
index 000000000000..f6667638c642
--- /dev/null
+++ b/www-servers/pound/pound-3.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="${P/p/P}"
+
+DESCRIPTION="A http/https reverse-proxy and load-balancer"
+HOMEPAGE="https://www.apsis.ch/pound.html"
+SRC_URI="https://www.apsis.ch/pound/${MY_P}.tgz"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+DEPEND="
+ dev-libs/libpcre:=
+ dev-libs/libyaml:=
+ dev-libs/nanomsg:=
+ dev-libs/openssl:=
+ net-libs/mbedtls:=
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hpack.patch
+)
+
+src_install() {
+ rm GPL.txt || die
+
+ dosbin "${BUILD_DIR}"/pound
+ doman "${S}"/man/pound.8
+ einstalldocs
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution;"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80)"
+ elog "for gentoo is given in \"/etc/pound.cfg\"."
+}