summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/xhost
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/xhost')
-rw-r--r--x11-apps/xhost/Manifest2
-rw-r--r--x11-apps/xhost/metadata.xml5
-rw-r--r--x11-apps/xhost/xhost-1.0.6.ebuild21
-rw-r--r--x11-apps/xhost/xhost-1.0.7.ebuild21
4 files changed, 49 insertions, 0 deletions
diff --git a/x11-apps/xhost/Manifest b/x11-apps/xhost/Manifest
new file mode 100644
index 000000000000..825d1df18d1b
--- /dev/null
+++ b/x11-apps/xhost/Manifest
@@ -0,0 +1,2 @@
+DIST xhost-1.0.6.tar.bz2 133176 SHA256 a6f5b922df0a7be5d3ba43f525fa8e69c539c738418f013a0b7adaa423a89dc2 SHA512 4e9b8b5b3a13b995e4f3596b26fa637d5892936090516eef1eb296c257358496ed5ad7b5c1e924003fcc18b6c8d4592f83e515d66a605a895f1d9fdc5d064f1a WHIRLPOOL 012c875be11a4cb6e4df884659fc08218e2f1ee3d8499c60bcd7d5227a7a0bad23c41fdfbf566eafc690b61dfdedab9e88bc47e8123816190baf871b616226f9
+DIST xhost-1.0.7.tar.bz2 135767 SHA256 93e619ee15471f576cfb30c663e18f5bc70aca577a63d2c2c03f006a7837c29a SHA512 670a8c97291565f6c36c94e135f7bd60a572bb42b4fca9d2460823db0d0576187c64f9b876ed60d348029d3f74a732862eea4ce889a6b6b9c97665746a38b1d7 WHIRLPOOL 4960cf6263d698a2e016e493441d358a44670251ac5c4e7545913de57c9e0e7064efa9dcc421dd6dd6f4c545d2265adc4f41d99701764a20d84d2adee37c6574
diff --git a/x11-apps/xhost/metadata.xml b/x11-apps/xhost/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-apps/xhost/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-apps/xhost/xhost-1.0.6.ebuild b/x11-apps/xhost/xhost-1.0.6.ebuild
new file mode 100644
index 000000000000..42a2f8a6a299
--- /dev/null
+++ b/x11-apps/xhost/xhost-1.0.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="Controls host and/or user access to a running X server"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXau"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS="$(use_enable ipv6)"
+}
diff --git a/x11-apps/xhost/xhost-1.0.7.ebuild b/x11-apps/xhost/xhost-1.0.7.ebuild
new file mode 100644
index 000000000000..b89c1e30edd7
--- /dev/null
+++ b/x11-apps/xhost/xhost-1.0.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="Controls host and/or user access to a running X server"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXau"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS="$(use_enable ipv6)"
+}