summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGino <onigino@protonmail.com>2018-08-19 17:24:08 -0700
committerMichał Górny <mgorny@gentoo.org>2018-09-15 00:46:49 +0200
commit77fbe85a7a8c331b5286f8e67911bc67ec8cee6a (patch)
tree22a448ed2868008579c71b871798bd2dc740330c /x11-apps
parentx11-apps/copyq: Add proxy maintainer(onigino) (diff)
downloadgentoo-77fbe85a7a8c331b5286f8e67911bc67ec8cee6a.tar.gz
gentoo-77fbe85a7a8c331b5286f8e67911bc67ec8cee6a.tar.bz2
gentoo-77fbe85a7a8c331b5286f8e67911bc67ec8cee6a.zip
x11-apps/copyq: Add new version 3.5.0
Closes: https://github.com/gentoo/gentoo/pull/9259
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/copyq/Manifest1
-rw-r--r--x11-apps/copyq/copyq-3.5.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-apps/copyq/Manifest b/x11-apps/copyq/Manifest
index 75dbe8eb070f..bcf3fb2265bd 100644
--- a/x11-apps/copyq/Manifest
+++ b/x11-apps/copyq/Manifest
@@ -1 +1,2 @@
+DIST CopyQ-3.5.0.tar.gz 3004460 BLAKE2B 30b2d732e87dd5ffea4d07adec14a377feddf2b7e89caf235e0a6bde5781419ec186bf40c687f14d658603ed3aebe43e5010a062560748a8dc00311f0f52a821 SHA512 9e662c8f80a59d58fbc8c51990682bfe61582ebdeba240e49996aab618b0a118422b0f2023952ef8cdf8e00f50ec4d7c67bd874abacf564226fb096dcc6d944d
DIST copyq-2.8.1.tar.gz 1573991 BLAKE2B 464c7fb462638ae717ee70dffcf5fb6eaf628dd4640c9db9d757769ac07479424fc953d81c92ed0e11015802432a9e556171994e8e2da7d0ce11868dcdf57cb6 SHA512 77602d39b0cb5fd0c8bd8d6c1ba5079e95ad72dc846c3e273556ffe029732e65bfd0951954de856c894bd7b6ebae816dfe7048040d77f7f3cd07faa922260b57
diff --git a/x11-apps/copyq/copyq-3.5.0.ebuild b/x11-apps/copyq/copyq-3.5.0.ebuild
new file mode 100644
index 000000000000..1607b43b0199
--- /dev/null
+++ b/x11-apps/copyq/copyq-3.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_P=CopyQ-${PV}
+
+DESCRIPTION="Clipboard manager with advanced features"
+HOMEPAGE="https://github.com/hluk/CopyQ"
+SRC_URI="https://github.com/hluk/CopyQ/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test webkit"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ webkit? ( dev-qt/qtwebkit:5 )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ test? ( dev-qt/qttest:5 )
+"
+S=${WORKDIR}/$MY_P
+
+src_configure() {
+ local mycmakeargs=(
+ -DPLUGIN_INSTALL_PREFIX="/usr/$(get_libdir)/${PN}/plugins"
+ -DWITH_QT5=ON
+ -DWITH_TESTS=$(usex test)
+ -DWITH_WEBKIT=$(usex webkit)
+ )
+ cmake-utils_src_configure
+}