summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-10 21:38:26 -0700
committerMatt Turner <mattst88@gentoo.org>2022-07-10 21:57:54 -0700
commit77f75a678af220426bfdb8b8bdd7c2fe0656aa3a (patch)
tree50eee792d0a529d28a781c7d9f9884417df97a62 /x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild
parentx11-apps/xwud: Version bump to 1.0.6 (diff)
downloadgentoo-77f75a678af220426bfdb8b8bdd7c2fe0656aa3a.tar.gz
gentoo-77f75a678af220426bfdb8b8bdd7c2fe0656aa3a.tar.bz2
gentoo-77f75a678af220426bfdb8b8bdd7c2fe0656aa3a.zip
x11-drivers/xf86-input-synaptics: Version bump to 1.9.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild')
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild
new file mode 100644
index 000000000000..780964e36af6
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit linux-info xorg-3
+
+DESCRIPTION="Driver for Synaptics touchpads"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=x11-base/xorg-server-1.14
+ x11-libs/libX11
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0
+ kernel_linux? ( >=dev-libs/libevdev-0.4 )"
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ x11-base/xorg-proto"
+
+check_reqs() {
+ linux-info_pkg_setup
+
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ ewarn
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn
+ fi
+}
+
+pkg_pretend() {
+ check_reqs
+}
+
+pkg_setup() {
+ check_reqs
+}