summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-04 22:07:09 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-04 22:13:16 -0400
commit3772d11a3a6c14fa95b42391795ba28044f9d428 (patch)
tree10cf101953390c91092af3c1a3744e907b2fe999 /x11-drivers
parentsys-apps/man-pages: add 6.04 (diff)
downloadgentoo-3772d11a3a6c14fa95b42391795ba28044f9d428.tar.gz
gentoo-3772d11a3a6c14fa95b42391795ba28044f9d428.tar.bz2
gentoo-3772d11a3a6c14fa95b42391795ba28044f9d428.zip
x11-drivers/xf86-input-libinput: Version bump to 1.3.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-libinput/Manifest1
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-1.3.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/Manifest b/x11-drivers/xf86-input-libinput/Manifest
index dd09b0b53344..71b104a8772f 100644
--- a/x11-drivers/xf86-input-libinput/Manifest
+++ b/x11-drivers/xf86-input-libinput/Manifest
@@ -1 +1,2 @@
DIST xf86-input-libinput-1.2.1.tar.xz 312324 BLAKE2B 2ce0419b19306f38cd8adb4159270b3943893032480325243066800cb1256dc1e497756da004f42510a6f6c78b1a3b73a41feccc66d5ce9c7cf40595008abebc SHA512 3decf694861d1aa3c02d090e66c5ed5513818cb18e9863f1790e0c8122a972230fb903705062b8291e1709db9098623f1205c63ccfb68e552e104813414589c7
+DIST xf86-input-libinput-1.3.0.tar.xz 325664 BLAKE2B e96e375fe1326786fbb6920a9652780a64e08805ba02ec2a424fe97ca2834e55715c7f2245cf92d51c6e607a83fec8eadd4be737967348421a016427da11f13c SHA512 f81f408b37e5f98ee97337dc4da6e78449e554e0ab2a3c6791b089d2cb6d645d0206ddf9babbc2120ab8bfe3b1489314fe42503ee015cec41775024538f3a34f
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.3.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.3.0.ebuild
new file mode 100644
index 000000000000..18ad3d60904b
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+
+inherit linux-info xorg-3
+
+DESCRIPTION="X.org input driver based on libinput"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/libinput-1.23.0:0="
+DEPEND="${RDEPEND}
+ >=x11-base/xorg-proto-2021.5"
+
+DOCS=( "README.md" )
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}