summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-01-24 01:00:47 -0500
committerMatt Turner <mattst88@gentoo.org>2023-01-24 01:07:28 -0500
commite6ac76831d716668591a412fcdaa715bb39f813b (patch)
treeae81b9b2567ca1a3de2206dfcafcb25b25a84c8e /x11-drivers
parentx11-drivers/xf86-video-vmware: Version bump to 13.4.0 (diff)
downloadgentoo-e6ac76831d716668591a412fcdaa715bb39f813b.tar.gz
gentoo-e6ac76831d716668591a412fcdaa715bb39f813b.tar.bz2
gentoo-e6ac76831d716668591a412fcdaa715bb39f813b.zip
x11-drivers/xf86-video-qxl: Version bump to 0.1.6
Bug: https://bugs.gentoo.org/829759 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-qxl/Manifest1
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.6.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-qxl/Manifest b/x11-drivers/xf86-video-qxl/Manifest
index 54b4c99009e8..36c9889bd779 100644
--- a/x11-drivers/xf86-video-qxl/Manifest
+++ b/x11-drivers/xf86-video-qxl/Manifest
@@ -1 +1,2 @@
DIST xf86-video-qxl-0.1.5_p20200205.tar.xz 137452 BLAKE2B 1639a393dadcba251a8fe761d52112d51c29e70960524785343379ec088e69c5e2cbd1a9710d72c749dc8b7303b3eceb545fbaec82d5d22613f8ebb0a4e7aca8 SHA512 9a2ba4aa7ef61d3ea0043ff1e3a8f312b7fe00f707045bcb4e4fc1189786b9aba2b6e44696f47e7c215485044f6c953f831ed4da48d4098cd7b62555c74a79f8
+DIST xf86-video-qxl-0.1.6.tar.xz 438844 BLAKE2B 2236b8678975288e5a8d28689dc58c2808bfce6bc3d1a14fffd271695b3b5a4f322addb1cf43d96dfe636ef52d654574e45a5a877299a40debd8cfd26165f22e SHA512 f6a42355915d2e8f8a842dc24fe6d012d123aa6d23eedea1a4771fb08f88e0298d76741755b88304d76c66b3aae15f9fca74d062be395e499a82ee8f4507c7e0
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.6.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.6.ebuild
new file mode 100644
index 000000000000..5426539edca8
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+XORG_TARBALL_SUFFIX="xz"
+inherit python-single-r1 xorg-3
+
+DESCRIPTION="QEMU QXL paravirt video driver"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="xspice"
+REQUIRED_USE="xspice? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ xspice? (
+ app-emulation/spice
+ ${PYTHON_DEPS}
+ )
+ x11-base/xorg-server[-minimal]
+ >=x11-libs/libdrm-2.4.46"
+DEPEND="
+ ${RDEPEND}
+ >=app-emulation/spice-protocol-0.12.0
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ use xspice && python-single-r1_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_prepare() {
+ xorg-3_src_prepare
+
+ use xspice && python_fix_shebang scripts
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable xspice)
+ )
+ xorg-3_src_configure
+}