summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2024-10-15 19:36:44 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-10-16 14:27:39 +0200
commite081e082783227007577b3ba97867ed30ff69fd1 (patch)
treea9d0d464b04bae77ca1bac3e85cbeecdc1c14acc /x11-libs
parentnet-misc/dropbox: restore 205.4.5765 (diff)
downloadgentoo-e081e082783227007577b3ba97867ed30ff69fd1.tar.gz
gentoo-e081e082783227007577b3ba97867ed30ff69fd1.tar.bz2
gentoo-e081e082783227007577b3ba97867ed30ff69fd1.zip
x11-libs/gl2ps: Fix dependencies
Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39003 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gl2ps/gl2ps-1.4.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-libs/gl2ps/gl2ps-1.4.2-r1.ebuild b/x11-libs/gl2ps/gl2ps-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..457bb278a4fe
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.4.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="https://www.geuz.org/gl2ps/"
+SRC_URI="https://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc png zlib"
+
+RDEPEND="
+ media-libs/libglvnd
+ png? ( media-libs/libpng:0= )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-tex/tth
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.2-cmake.patch )
+
+src_prepare() {
+ cmake_src_prepare
+ sed '/^install.*TODO\.txt/d' -i "${S}"/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DENABLE_DOC="$(usex doc)"
+ -DENABLE_PNG="$(usex png)"
+ -DENABLE_ZLIB="$(usex zlib)"
+ -DOpenGL_GL_PREFERENCE=GLVND
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}