summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-27 18:33:40 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-03 18:14:16 -0700
commite9e83e797b43d263c2f92fe40be366b403a9c282 (patch)
treeb2359228e9141081c0d9feaab81429f958534a29 /x11-libs
parentx11-libs/pango: Switch to meson-multilib (diff)
downloadgentoo-e9e83e797b43d263c2f92fe40be366b403a9c282.tar.gz
gentoo-e9e83e797b43d263c2f92fe40be366b403a9c282.tar.bz2
gentoo-e9e83e797b43d263c2f92fe40be366b403a9c282.zip
x11-libs/pixman: Switch to meson-multilib
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pixman/pixman-0.40.0.ebuild12
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild12
2 files changed, 4 insertions, 20 deletions
diff --git a/x11-libs/pixman/pixman-0.40.0.ebuild b/x11-libs/pixman/pixman-0.40.0.ebuild
index daac74216757..65d7123b398b 100644
--- a/x11-libs/pixman/pixman-0.40.0.ebuild
+++ b/x11-libs/pixman/pixman-0.40.0.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson multilib-minimal multiprocessing toolchain-funcs
+inherit ${GIT_ECLASS} meson-multilib multiprocessing toolchain-funcs
DESCRIPTION="Low-level pixel manipulation routines"
HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
@@ -45,15 +45,7 @@ multilib_src_configure() {
meson_src_configure
}
-multilib_src_compile() {
- meson_src_compile
-}
-
multilib_src_test() {
export OMP_NUM_THREADS=$(makeopts_jobs)
- meson test -v -C "${BUILD_DIR}" -t 100 || die "tests failed"
-}
-
-multilib_src_install() {
- meson_src_install
+ meson_src_test -t 100
}
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
index 316d0b79f709..d79304a2d1a2 100644
--- a/x11-libs/pixman/pixman-9999.ebuild
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson multilib-minimal multiprocessing toolchain-funcs
+inherit ${GIT_ECLASS} meson-multilib multiprocessing toolchain-funcs
DESCRIPTION="Low-level pixel manipulation routines"
HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
@@ -45,15 +45,7 @@ multilib_src_configure() {
meson_src_configure
}
-multilib_src_compile() {
- meson_src_compile
-}
-
multilib_src_test() {
export OMP_NUM_THREADS=$(makeopts_jobs)
- meson test -v -C "${BUILD_DIR}" -t 100 || die "tests failed"
-}
-
-multilib_src_install() {
- meson_src_install
+ meson_src_test -t 100
}