summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-03-01 07:37:37 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-03-04 14:59:11 +0200
commit98c8397688f16da06947dd96c33cb5e97addac50 (patch)
tree4c0194d6cf6cac153ca1822939c3e636d43be052 /x11-misc/dunst
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.259,4.9.259,4.14.2... (diff)
downloadgentoo-98c8397688f16da06947dd96c33cb5e97addac50.tar.gz
gentoo-98c8397688f16da06947dd96c33cb5e97addac50.tar.bz2
gentoo-98c8397688f16da06947dd96c33cb5e97addac50.zip
x11-misc/dunst: version bump to 1.6.1
new maintainer Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/19719 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/dunst')
-rw-r--r--x11-misc/dunst/Manifest1
-rw-r--r--x11-misc/dunst/dunst-1.6.1.ebuild59
-rw-r--r--x11-misc/dunst/dunst-9999.ebuild41
-rw-r--r--x11-misc/dunst/files/dunst-1.6.1-no-Os.patch13
-rw-r--r--x11-misc/dunst/metadata.xml10
5 files changed, 105 insertions, 19 deletions
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index cdb476506379..46f77b7e0295 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1,2 +1,3 @@
DIST dunst-1.4.1.tar.gz 160124 BLAKE2B d618b3bffc8f4518f58d28e108a8aadf1ff71164f581632bc198b3d0a81f6efa0fff73513fa5d46ec4a7058bb1beb8d8a51cb01e4621c76f8d3f8653cc6e2270 SHA512 43667898e123ef0dea59e2ca55a76686785906e44b453b2a86bdf361045b3f6b751a2e81fa9f562127f80bf47f8c9248960c37f8365dbbe409d72ddc3deb34fb
DIST dunst-1.5.0.tar.gz 169272 BLAKE2B 63c33e62f61aefec67e5420d5afe41808cf8b377c0decde92781ef541315c955b715aa78c6e1a2288b916cabf7830d5621366d53731d477e3c4a6a60349f4c8b SHA512 2057dc530adce1dac89f12f4ca55e9186d378ccc2b406e0fa20d43bc69f671dc303b608a4fea781ab1193bd2e159dcbdecf3baf50e27ac9b0f164965b5824c85
+DIST dunst-1.6.1.tar.gz 217267 BLAKE2B 267e5be6a079097fb5a677bd2451b0e5bcbcddadf4c4de9af87d4eab7dd90b61908f140db3f1238b6a79d370fc3bb89c062c6b4deeefae6c9c0069b55017e907 SHA512 079ffd0ff75f1865b68cb8db261849cbe4f68b5c632c39ef8f7a3d193ff3eba3734bca31cb7268f27c9a411aec56e4c484c383b419bc0b4755b7d80ede84cd96
diff --git a/x11-misc/dunst/dunst-1.6.1.ebuild b/x11-misc/dunst/dunst-1.6.1.ebuild
new file mode 100644
index 000000000000..b4ea0aaabb02
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.6.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Customizable and lightweight notification-daemon"
+HOMEPAGE="https://dunst-project.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dunst-project/dunst"
+else
+ SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test wayland"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X,glib]
+ x11-libs/gdk-pixbuf
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libnotify
+ x11-libs/pango[X]
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.1-no-Os.patch )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+ default
+}
+
+src_compile() {
+ emake WAYLAND=$(usex wayland 1 0) SYSTEMD=0
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" \
+ -i dunst.systemd.service.in > dunst.service
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ systemd_dounit dunst.service
+}
diff --git a/x11-misc/dunst/dunst-9999.ebuild b/x11-misc/dunst/dunst-9999.ebuild
index f341b6af6627..b4ea0aaabb02 100644
--- a/x11-misc/dunst/dunst-9999.ebuild
+++ b/x11-misc/dunst/dunst-9999.ebuild
@@ -1,16 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+inherit systemd toolchain-funcs
DESCRIPTION="Customizable and lightweight notification-daemon"
-HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
-EGIT_REPO_URI="https://github.com/${PN}-project/${PN}"
+HOMEPAGE="https://dunst-project.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dunst-project/dunst"
+else
+ SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
+IUSE="test wayland"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/glib:2
@@ -23,28 +31,29 @@ DEPEND="
x11-libs/libXrandr
x11-libs/libnotify
x11-libs/pango[X]
+ wayland? ( dev-libs/wayland )
"
+RDEPEND="${DEPEND}"
BDEPEND="
dev-lang/perl
virtual/pkgconfig
-"
-RDEPEND="
- ${DEPEND}
+ wayland? ( dev-libs/wayland-protocols )
"
-src_prepare() {
- sed -i -e "/^CFLAGS/ { s:-g::;s:-O.:: }" config.mk || die
-
- default
-}
+PATCHES=( "${FILESDIR}"/${PN}-1.6.1-no-Os.patch )
src_configure() {
tc-export CC PKG_CONFIG
default
}
-src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
+src_compile() {
+ emake WAYLAND=$(usex wayland 1 0) SYSTEMD=0
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" \
+ -i dunst.systemd.service.in > dunst.service
+}
- dodoc AUTHORS CHANGELOG.md README.md RELEASE_NOTES
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ systemd_dounit dunst.service
}
diff --git a/x11-misc/dunst/files/dunst-1.6.1-no-Os.patch b/x11-misc/dunst/files/dunst-1.6.1-no-Os.patch
new file mode 100644
index 000000000000..90a1de94de95
--- /dev/null
+++ b/x11-misc/dunst/files/dunst-1.6.1-no-Os.patch
@@ -0,0 +1,13 @@
+diff --git a/config.mk b/config.mk
+index 54426a7..2e18031 100644
+--- a/config.mk
++++ b/config.mk
+@@ -36,7 +36,7 @@ endif
+
+ # flags
+ DEFAULT_CPPFLAGS = -D_DEFAULT_SOURCE -DVERSION=\"${VERSION}\"
+-DEFAULT_CFLAGS = -g --std=gnu99 -pedantic -Wall -Wno-overlength-strings -Os ${STATIC} ${ENABLE_WAYLAND}
++DEFAULT_CFLAGS = --std=gnu99 -pedantic -Wall -Wno-overlength-strings ${STATIC} ${ENABLE_WAYLAND}
+ DEFAULT_LDFLAGS = -lm -lrt
+
+ CPPFLAGS_DEBUG := -DDEBUG_BUILD
diff --git a/x11-misc/dunst/metadata.xml b/x11-misc/dunst/metadata.xml
index de3681ee1319..1472d6311cad 100644
--- a/x11-misc/dunst/metadata.xml
+++ b/x11-misc/dunst/metadata.xml
@@ -1,9 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type='project'>
- <email>desktop-misc@gentoo.org</email>
- <name>Gentoo Desktop Miscellaneous Project</name>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
<use>
<flag name="dunstify">Experimental replacement for notify-send.</flag>