summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/icewmcp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/icewmcp')
-rw-r--r--x11-misc/icewmcp/Manifest1
-rw-r--r--x11-misc/icewmcp/icewmcp-3.2-r2.ebuild64
-rw-r--r--x11-misc/icewmcp/icewmcp-3.2-r4.ebuild62
-rw-r--r--x11-misc/icewmcp/metadata.xml8
4 files changed, 135 insertions, 0 deletions
diff --git a/x11-misc/icewmcp/Manifest b/x11-misc/icewmcp/Manifest
new file mode 100644
index 000000000000..ed8d1e8c30eb
--- /dev/null
+++ b/x11-misc/icewmcp/Manifest
@@ -0,0 +1 @@
+DIST IceWMControlPanel-3.2.tar.bz2 586044 SHA256 6259d27b5de151049b245cac17606ba77d055766ef1706363dc301085c925af9 SHA512 017b257bb30c49eb0b13a9570df70f6f8ccb55087121440cd1331f8364ddc6c23fae26c98bae1bd831f2a9fc52bef531cab9313f3e2ea209ce26d776ee64c47e WHIRLPOOL f133b4998528c10071c39bab3187705ac7f5c6ee87bd2b73de395a88b0953df217b9e4cc2216ca9bf14ac70b190c30879f04eba2f4a1d342b30e994952a4e17a
diff --git a/x11-misc/icewmcp/icewmcp-3.2-r2.ebuild b/x11-misc/icewmcp/icewmcp-3.2-r2.ebuild
new file mode 100644
index 000000000000..1a246aae445f
--- /dev/null
+++ b/x11-misc/icewmcp/icewmcp-3.2-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+PYTHON_DEPEND="2"
+
+inherit python multilib
+
+S=${WORKDIR}/INSTALL-IceWMCP
+MY_PN=IceWMControlPanel
+MY_DEST="usr/$(get_libdir)/${P}"
+MY_BIN="usr/bin"
+
+DESCRIPTION="A complete control panel for IceWM using gtk & python"
+HOMEPAGE="http://icesoundmanager.sourceforge.net/index.php"
+SRC_URI="mirror://sourceforge/icesoundmanager/${MY_PN}-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+DEPEND="x11-wm/icewm
+ dev-python/pygtk:2
+ x11-libs/gtk+:2"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ dodir "${MY_DEST}/"
+ dodir "${MY_BIN}/"
+ dodoc "${S}"/doc/* "${S}"/licenses/*
+ cp "${S}"/* "${D}"/${MY_DEST}
+ cp -R "${S}"/applets "${S}"/applet-icons "${S}"/help "${S}"/icons \
+ "${S}"/locale "${S}"/pixmaps "${D}"/${MY_DEST}/
+ # create executable shortcuts to the python scripts
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCP.py" > ${T}/IceWMCP
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPKeyboard.py" > ${T}/IceWMCP-Keyboard
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPMouse.py" > ${T}/IceWMCP-Mouse
+ echo -e "#!/bin/bash \n python /${MY_DEST}/pyspool.py" > ${T}/IceWMCP-PySpool
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPWallpaper.py" > ${T}/IceWMCP-Wallpaper
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPWinOptions.py" > ${T}/IceWMCP-WinOptions
+ echo -e "#!/bin/bash \n python /${MY_DEST}/phrozenclock.py" > ${T}/PhrozenClock
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icesound.py" > ${T}/IceSoundManager
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCP_GtkPCCard.py" > ${T}/GtkPCCard
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceMe.py" > ${T}/iceme
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icepref.py" > ${T}/icepref
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icepref_td.py" > ${T}/icepref_td
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPGtkIconSelection.py" > ${T}/IceWMCP-Icons
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPEnergyStar.py" > ${T}/IceWMCP-EnergyStar
+ dobin "${T}"/*
+}
+
+pkg_postinst() {
+ einfo "Some of the icons displayed by IceWMCP may be pointing to"
+ einfo "programs which are not on your system! You can hide them"
+ einfo "using the Configuration window (Ctrl+C) or change them"
+ einfo "by editing the files in"
+ einfo "/${MY_DEST}/applets and"
+ einfo "/${MY_DEST}/applet-icons."
+}
diff --git a/x11-misc/icewmcp/icewmcp-3.2-r4.ebuild b/x11-misc/icewmcp/icewmcp-3.2-r4.ebuild
new file mode 100644
index 000000000000..7c97bf317f7a
--- /dev/null
+++ b/x11-misc/icewmcp/icewmcp-3.2-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit multilib python-single-r1
+
+MY_PN=IceWMControlPanel
+DESCRIPTION="A complete control panel for IceWM using gtk & python"
+HOMEPAGE="http://icesoundmanager.sourceforge.net/index.php"
+SRC_URI="mirror://sourceforge/icesoundmanager/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-python/pygtk:2
+ x11-libs/gtk+:2
+ x11-wm/icewm
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/INSTALL-IceWMCP
+
+src_prepare() {
+ rm -rf licenses
+ mv doc .. || die
+}
+
+src_install() {
+ local dest="/usr/$(get_libdir)/${P}"
+ insinto ${dest}
+ doins -r *
+
+ local w wraps=(
+ "IceWMCP.py IceWMCP"
+ "IceWMCPKeyboard.py IceWMCP-Keyboard"
+ "IceWMCPMouse.py IceWMCP-Mouse"
+ "pyspool.py IceWMCP-PySpool"
+ "IceWMCPWallpaper.py IceWMCP-Wallpaper"
+ "IceWMCPWinOptions.py IceWMCP-WinOptions"
+ "phrozenclock.py PhrozenClock"
+ "icesound.py IceSoundManager"
+ "IceWMCP_GtkPCCard.py GtkPCCard"
+ "IceMe.py iceme"
+ "icepref.py icepref"
+ "icepref_td.py icepref_td"
+ "IceWMCPGtkIconSelection.py IceWMCP-Icons"
+ "IceWMCPEnergyStar.py IceWMCP-EnergyStar"
+ )
+ for w in "${wraps[@]}" ; do
+ set -- ${w}
+ printf '#!/bin/sh\nexec %s %s/%s\n' "${EPYTHON}" "${dest}" "$1" > "${T}"/$2
+ dobin "${T}"/$2 || die
+ done
+
+ dodoc ../doc/*.txt
+ dohtml ../doc/*.html
+ python_optimize "${D}/${dest}"
+}
diff --git a/x11-misc/icewmcp/metadata.xml b/x11-misc/icewmcp/metadata.xml
new file mode 100644
index 000000000000..0c74c3eb46a6
--- /dev/null
+++ b/x11-misc/icewmcp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">icesoundmanager</remote-id>
+ </upstream>
+</pkgmetadata>