summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-03-20 22:02:05 +0100
committerJeroen Roovers <jer@gentoo.org>2019-03-20 22:03:20 +0100
commitb673b69a07dfaec985c3666e07abfe9ff69709a9 (patch)
treebca5ba957c0f1bc9e148aa4c155a89284ee0d1bd /x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild
parentdev-lang/php: amd64 stable wrt bug #681074 (diff)
downloadgentoo-b673b69a07dfaec985c3666e07abfe9ff69709a9.tar.gz
gentoo-b673b69a07dfaec985c3666e07abfe9ff69709a9.tar.bz2
gentoo-b673b69a07dfaec985c3666e07abfe9ff69709a9.zip
x11-misc/simpleswitcher: Add snapshot, move live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild')
-rw-r--r--x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild b/x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild
new file mode 100644
index 000000000000..6088df3f2461
--- /dev/null
+++ b/x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+SSHASH="cbc89a71a61fd2d164c3fdc3ef4d3fa809c1741a"
+DESCRIPTION="lightweight EWMH window switcher with features and looks of dmenu"
+HOMEPAGE="https://github.com/seanpringle/simpleswitcher"
+SRC_URI="${HOMEPAGE}/archive/${SSHASH}.tar.gz -> ${P}-${SSHASH}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXres
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+S=${WORKDIR}/${PN}-${SSHASH}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}