summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/sunflower
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/sunflower')
-rw-r--r--x11-misc/sunflower/Manifest1
-rw-r--r--x11-misc/sunflower/files/sunflower5
-rw-r--r--x11-misc/sunflower/metadata.xml18
-rw-r--r--x11-misc/sunflower/sunflower-0.2_alpha59.ebuild93
4 files changed, 117 insertions, 0 deletions
diff --git a/x11-misc/sunflower/Manifest b/x11-misc/sunflower/Manifest
new file mode 100644
index 000000000000..74b28e15d453
--- /dev/null
+++ b/x11-misc/sunflower/Manifest
@@ -0,0 +1 @@
+DIST sunflower-0.2-59.tgz 790126 SHA256 f0497c18870487361780a776bf31235473c20ef66bc56a95c6048e00c399b525 SHA512 e97076eb1c57d52b8fd95501259acaaa9a429f9daacc30ef587cce2f3419433f5aa4554e0e86beeceda208b4be425b98c64c6ced04e36e86b2b4f803176c37f9 WHIRLPOOL 6126fda9675b9938e3a12620e48e22c6d23253890f47c5ab34a7322280d27d1d78e2e3745ccf55831094efb987835f9f0f159dbe109732da2c236096f485cfee
diff --git a/x11-misc/sunflower/files/sunflower b/x11-misc/sunflower/files/sunflower
new file mode 100644
index 000000000000..192d4b99e1ae
--- /dev/null
+++ b/x11-misc/sunflower/files/sunflower
@@ -0,0 +1,5 @@
+#!/usr/bin/env python
+
+import os
+os.chdir("@SITEDIR@")
+import sunflower.Sunflower
diff --git a/x11-misc/sunflower/metadata.xml b/x11-misc/sunflower/metadata.xml
new file mode 100644
index 000000000000..d9df2048b4c0
--- /dev/null
+++ b/x11-misc/sunflower/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>henrique.ribeiro.dias@gmail.com</email>
+ <name>Henrique Dias</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">MeanEYE/Sunflower</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/sunflower/sunflower-0.2_alpha59.ebuild b/x11-misc/sunflower/sunflower-0.2_alpha59.ebuild
new file mode 100644
index 000000000000..689ac28550eb
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.2_alpha59.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils fdo-mime gnome2-utils python-r1
+
+MY_PN="Sunflower"
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ http://sunflower-fm.org/"
+SRC_URI="http://sunflower-fm.org/pub/sunflower-${PV/_alpha/-}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/notify-python-0.1[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ find "${S}" -name "*.py[co]" -delete || die
+ find "${S}"/translations -name "*.po" -delete || die
+ rm "${S}"/translations/${PN}.pot || die
+
+ sed -i \
+ -e '/^application_file/s/os.path.dirname(sys.argv\[0\])/os.getcwd()/' \
+ ${MY_PN}.py || die
+}
+
+src_install() {
+ touch __init__.py || die
+ installme() {
+ # install modules
+ python_moduleinto ${PN}
+ python_domodule images application ${MY_PN}.py \
+ AUTHORS CHANGES COPYING DEPENDS TODO __init__.py
+
+ # generate and install startup scripts
+ sed \
+ -e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
+ "${FILESDIR}"/${PN} > "${WORKDIR}"/${PN} || die
+ python_doscript "${WORKDIR}"/${PN}
+ }
+
+ # install for all enabled implementations
+ python_foreach_impl installme
+
+ insinto /usr/share/locale
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/translations ; echo *) ; do
+ if has ${i} ${LINGUAS} ; then
+ doins -r "${S}"/translations/${i}
+ fi
+ done
+ else
+ doins -r "${S}"/translations/*
+ fi
+
+ newicon -s 64 images/${PN}_64.png ${PN}.png
+ doicon -s scalable images/${PN}.svg
+ newmenu ${MY_PN}.desktop ${PN}.desktop
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ # TODO: better description
+ elog "optional dependencies:"
+ elog " dev-python/libgnome-python"
+ elog " media-libs/mutagen"
+ elog " x11-libs/vte:0[python] (terminal support)"
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}