summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 04:59:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:11 -0400
commit0da382f0a5c38cce6e70a3724471a6c7981730d7 (patch)
tree5647a20f8684cd4afc3e92418b8d7cdf57e4b297 /x11-misc/xautolock
parentx11-misc/x2x: fixup build deps (diff)
downloadgentoo-0da382f0a5c38cce6e70a3724471a6c7981730d7.tar.gz
gentoo-0da382f0a5c38cce6e70a3724471a6c7981730d7.tar.bz2
gentoo-0da382f0a5c38cce6e70a3724471a6c7981730d7.zip
x11-misc/xautolock: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/xautolock')
-rw-r--r--x11-misc/xautolock/xautolock-2.2_p7.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-misc/xautolock/xautolock-2.2_p7.ebuild b/x11-misc/xautolock/xautolock-2.2_p7.ebuild
index 03cb72de3b8f..fd84f8e1b114 100644
--- a/x11-misc/xautolock/xautolock-2.2_p7.ebuild
+++ b/x11-misc/xautolock/xautolock-2.2_p7.ebuild
@@ -19,10 +19,13 @@ KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 sparc x86"
RDEPEND="
x11-libs/libXScrnSaver
"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
BDEPEND="
app-text/rman
- x11-base/xorg-proto
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1
"
PATCHES=(
@@ -38,7 +41,7 @@ src_prepare() {
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {