summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-01-30 20:47:14 +0200
committerSam James <sam@gentoo.org>2024-01-30 19:27:55 +0000
commit5085ce2d6bb335ea1179d6021ffb2d7081120fa8 (patch)
tree614d85681ce785ea25ab9c5fd3deba5b641ea30b /x11-misc
parentsci-libs/pdal: bump 2.6.2 (diff)
downloadgentoo-5085ce2d6bb335ea1179d6021ffb2d7081120fa8.tar.gz
gentoo-5085ce2d6bb335ea1179d6021ffb2d7081120fa8.tar.bz2
gentoo-5085ce2d6bb335ea1179d6021ffb2d7081120fa8.zip
x11-misc/copyq: fix plugin dir envvar patch
* Fixes issue where plugins can't be found. * Didn't appreciate the fact that QDir will initialise at . if empty... Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/35102 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/copyq/copyq-7.1.0-r1.ebuild (renamed from x11-misc/copyq/copyq-7.1.0.ebuild)4
-rw-r--r--x11-misc/copyq/files/copyq-7.1.0-support-plugin-dir-envvar-r1.patch (renamed from x11-misc/copyq/files/copyq-7.1.0-support-plugin-dir-envvar.patch)12
2 files changed, 8 insertions, 8 deletions
diff --git a/x11-misc/copyq/copyq-7.1.0.ebuild b/x11-misc/copyq/copyq-7.1.0-r1.ebuild
index 8d39c5de4835..85ed9029ecee 100644
--- a/x11-misc/copyq/copyq-7.1.0.ebuild
+++ b/x11-misc/copyq/copyq-7.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -69,7 +69,7 @@ PATCHES=(
"${FILESDIR}/copyq-7.1.0-fix-qt-6.6.0-build.patch"
"${FILESDIR}/copyq-7.1.0-fix-test-failure-due-to-invalid-regex.patch"
"${FILESDIR}/copyq-7.1.0-fix-gpg-2.1-support.patch"
- "${FILESDIR}/copyq-7.1.0-support-plugin-dir-envvar.patch"
+ "${FILESDIR}/copyq-7.1.0-support-plugin-dir-envvar-r1.patch"
)
src_prepare() {
diff --git a/x11-misc/copyq/files/copyq-7.1.0-support-plugin-dir-envvar.patch b/x11-misc/copyq/files/copyq-7.1.0-support-plugin-dir-envvar-r1.patch
index 21c60f87011b..d2d0ec94b659 100644
--- a/x11-misc/copyq/files/copyq-7.1.0-support-plugin-dir-envvar.patch
+++ b/x11-misc/copyq/files/copyq-7.1.0-support-plugin-dir-envvar-r1.patch
@@ -1,6 +1,6 @@
-From 32b45b42f0d9dbdaae077f81d11fff7bd2455492 Mon Sep 17 00:00:00 2001
+From 6d20653b924481048fa017dc40cf9d7360f95a13 Mon Sep 17 00:00:00 2001
From: Alfred Wingate <parona@protonmail.com>
-Date: Wed, 6 Dec 2023 06:16:36 +0200
+Date: Tue, 30 Jan 2024 20:44:18 +0200
Subject: [PATCH] itemfactory: Add support for setting plugin dir in the
environment
@@ -12,11 +12,11 @@ Signed-off-by: Alfred Wingate <parona@protonmail.com>
bool findPluginDir(QDir *pluginsDir)
{
+ QString pluginDirEnv = qEnvironmentVariable("COPYQ_PLUGIN_DIR");
-+ if ( !pluginDirEnv.isEmpty() )
++ if ( !pluginDirEnv.isEmpty() ) {
+ pluginsDir->setPath(pluginDirEnv);
-+
-+ if ( pluginsDir->isReadable() )
-+ return true;
++ if ( pluginsDir->isReadable() )
++ return true;
++ }
+
#ifdef COPYQ_PLUGIN_PREFIX
pluginsDir->setPath(COPYQ_PLUGIN_PREFIX);