summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-28 07:02:21 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-30 15:42:41 -0400
commit5ab58c3a7f79787f5652ee4cf23859654f46cb9e (patch)
treecb87cf5bedeb108ba57d7134e903a00134653333 /x11-misc
parentdev-java/byaccj: Stabilize 1.15-r3 amd64, #855359 (diff)
downloadgentoo-5ab58c3a7f79787f5652ee4cf23859654f46cb9e.tar.gz
gentoo-5ab58c3a7f79787f5652ee4cf23859654f46cb9e.tar.bz2
gentoo-5ab58c3a7f79787f5652ee4cf23859654f46cb9e.zip
x11-misc/sxhkd: EAPI7->8 and tidy
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild (renamed from x11-misc/sxhkd/sxhkd-0.6.2.ebuild)19
1 files changed, 14 insertions, 5 deletions
diff --git a/x11-misc/sxhkd/sxhkd-0.6.2.ebuild b/x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild
index 62e4eb5b3616..bdc5518c83d9 100644
--- a/x11-misc/sxhkd/sxhkd-0.6.2.ebuild
+++ b/x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs systemd
DESCRIPTION="Simple X hotkey daemon"
@@ -12,9 +13,11 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~riscv ~x86"
-RDEPEND="x11-libs/libxcb
+RDEPEND="
+ x11-libs/libxcb:=
x11-libs/xcb-util-keysyms"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
x11-libs/xcb-util"
src_compile() {
@@ -22,6 +25,12 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" DOCPREFIX="${EPREFIX}/usr/share/doc/${PF}" install
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCPREFIX="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ emake "${emakeargs[@]}" install
+
systemd_dounit contrib/systemd/${PN}.service
}