summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-12 15:13:07 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-12 15:13:07 -0400
commit655f0cd948ea3609c6d4b5686b2600e55029824b (patch)
tree487bc022f48f265b1ba6cfdbb6fcfc806b750dae /x11-misc
parentdev-python/jikanpy: Update remote-id (diff)
downloadgentoo-655f0cd948ea3609c6d4b5686b2600e55029824b.tar.gz
gentoo-655f0cd948ea3609c6d4b5686b2600e55029824b.tar.bz2
gentoo-655f0cd948ea3609c6d4b5686b2600e55029824b.zip
x11-misc/compose-tables: Version bump to 1.8.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/compose-tables/Manifest1
-rw-r--r--x11-misc/compose-tables/compose-tables-1.8.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index 8f594c24190f..12b6d82b1fd3 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1,2 +1,3 @@
DIST libX11-1.7.5.tar.xz 1853152 BLAKE2B 95ceccbfd37d8a749a533bdc03feba94236a47185a2cd7ad6592c534c17636906b735aa5800d810d13d3e342e3dbe281bb1f1f3ecab9d07e6a6a50f33beef8af SHA512 ef33e2f631226cab27657f46e1fd4cfc928f62f928d8297474e7b993017c8f92b60272eed6515990cdf3a9d34581837b7a3896e584f3546dd26f3790034df347
+DIST libX11-1.8.1.tar.xz 1818460 BLAKE2B 7602b4d8c65ea3160f81096b4e022b5462e49d96b36dee70fe06e972329dc9d70bbd462e2079da03ba5647d7a72bf03e29aab23c60bcc206c95d770655622226 SHA512 2e36d2c47519e0cb2697f588c0ccdf73fbe75c2163f0855c78f7052dc9e920bca081f9d5e39c707a14067f101faef74fc758c8862eeba675b1535b43119d533a
DIST libX11-1.8.tar.xz 1782508 BLAKE2B 15a41cbcdb54d68cd54b6fa4147d55d277a6c091af7d38341ec261b42c547acf981270ceebec5abb3fcc15da5c1e05b7908114e157555f8184234922e3c05fde SHA512 64899ba9efbda00211daf08534a2a98eba86bb377980d21ce319106075cd36b511b17245d02e8ebd1045e7c2147f2c005004bcf579121138be7a7b879eeca83b
diff --git a/x11-misc/compose-tables/compose-tables-1.8.1.ebuild b/x11-misc/compose-tables/compose-tables-1.8.1.ebuild
new file mode 100644
index 000000000000..64f043d5d3e9
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND="!<x11-libs/libX11-1.7.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}