summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-27 12:48:04 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-11-08 23:41:31 +0100
commit13813ec13f56dc45d52c74298ccb09537bb1bde5 (patch)
tree526d8351116e09f983838b6a92185c5136438368 /x11-plugins/pidgin-telegram
parentwww-apps/cgp: drop old version. (diff)
downloadgentoo-13813ec13f56dc45d52c74298ccb09537bb1bde5.tar.gz
gentoo-13813ec13f56dc45d52c74298ccb09537bb1bde5.tar.bz2
gentoo-13813ec13f56dc45d52c74298ccb09537bb1bde5.zip
x11-plugins/pidgin-telegram: bump to EAPI=7.
Also updated metadata.xml. Closes: https://bugs.gentoo.org/669764 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10252 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-telegram')
-rw-r--r--x11-plugins/pidgin-telegram/metadata.xml4
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.3.1-r1.ebuild51
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-telegram/metadata.xml b/x11-plugins/pidgin-telegram/metadata.xml
index c8fb36cb1a77..e23b905712c1 100644
--- a/x11-plugins/pidgin-telegram/metadata.xml
+++ b/x11-plugins/pidgin-telegram/metadata.xml
@@ -14,6 +14,10 @@
which can be used directly in net-im/pidgin.
Telegram is a cloud-based instant messaging and voice over IP service.
</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/majn/telegram-purple/issues</bugs-to>
+ <remote-id type="github">majn/telegram-purple</remote-id>
+ </upstream>
<use>
<flag name="gcrypt">Use dev-libs/libgcrypt instead of dev-libs/openssl.</flag>
</use>
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.3.1-r1.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..9624bde7b852
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.3.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
+HOMEPAGE="https://github.com/majn/telegram-purple"
+SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegram-purple_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="gcrypt libressl +nls +webp"
+
+RDEPEND="
+ net-im/pidgin
+ sys-libs/zlib:=
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ !gcrypt? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ nls? ( sys-devel/gettext )
+ webp? ( media-libs/libwebp:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/telegram-purple"
+
+DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
+
+src_prepare() {
+ default
+
+ # Remove '-Werror' to make it compile
+ find -name 'Makefile*' -exec sed -i -e 's/-Werror //' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable gcrypt)
+ $(use_enable nls translation)
+ $(use_enable webp libwebp)
+ )
+
+ econf "${myeconfargs[@]}"
+}