summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmsmixer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmsmixer')
-rw-r--r--x11-plugins/wmsmixer/Manifest1
-rw-r--r--x11-plugins/wmsmixer/metadata.xml10
-rw-r--r--x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/wmsmixer/Manifest b/x11-plugins/wmsmixer/Manifest
new file mode 100644
index 000000000000..3d79f4df8755
--- /dev/null
+++ b/x11-plugins/wmsmixer/Manifest
@@ -0,0 +1 @@
+DIST wmsmixer-0.5.1.tar.gz 33350 RMD160 2f8ab0bf8571b9ea1e111f5e22c3df8ea017dec7 SHA1 32473bf99b7c0dfa4a2b7d0d850288354aebde58 SHA256 eee60a40ba92e4c2c9a038c6e51cd3bd62b24b38a096d091dc60dfd26f0c5daa
diff --git a/x11-plugins/wmsmixer/metadata.xml b/x11-plugins/wmsmixer/metadata.xml
new file mode 100644
index 000000000000..604b037085ff
--- /dev/null
+++ b/x11-plugins/wmsmixer/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+WMsmixer is a hack to wmmixer which makes some changes to the display
+and adds a few new features, most notably scrollwheel support. It also
+includes a numeric volume indicator.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild b/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
new file mode 100644
index 000000000000..f04e2ddeaee0
--- /dev/null
+++ b/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+IUSE=""
+DESCRIPTION="fork of wmmixer adding scrollwheel support and other features"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/63"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/268/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_compile() {
+ g++ ${CFLAGS} -I/usr/X11R6/include -c -o wmsmixer.o wmsmixer.cc
+ rm -f wmsmixer
+ g++ ${LDFLAGS} -o wmsmixer ${CFLAGS} -L/usr/X11R6/lib wmsmixer.o -lXpm -lXext -lX11
+}
+
+src_install() {
+ insinto /usr/bin
+ insopts -m0655
+ doins wmsmixer
+ dodoc README README.wmmixer
+}